Support » Plugin: Enable Multi-Site » [Plugin: Enable Multi-Site] Enable Mult-Site only partially worked

  • Resolved Tevya


    I was advised to come and post this here just to let the creator(s) of Enable Multi-Site know about what happened when I tried to use the plugin. I installed it on a fresh WP 3 install and everything appeared to go fine. I used sub-folders instead of sub-domains, so I could avoid the issue with wild-card subdomains on my shared hosting.

    With the main site, everything seemed fine. I got the super-admin access and menu, etc. However, when I went to setup the first sub-site it only partially worked. It installed it, but the paths (to things like the backend and theme files) all included the subfolder of the sub-site in the path, which means they didn’t work.

    I contacted my host, since I was advised it had something to do with httpdconf or AllowOverride. They looked into it, and this was their response:

    your problem is now fixed. You did not have this line in the wp-config.php file:

    define( 'WP_ALLOW_MULTISITE', true );

    This actually enables the MU core within wordpress 3.0.1. Then you needed to go to Tools -> Networks and copy the .htaccess code because you were missing a whole bunch of .htaccess code as well. Clear your browser cache and you will see that this page now works and no css files are missing now

    This had nothing to do with httpdconf or AllowOverride.

    My understanding was that these were exactly the things Enable Multi-Site was supposed to do, but apparently it didn’t work in this case, for some reason. It all works now so I’m not in need of any support, but it was recommended that I let you know by posting here. If you’d like more info, you can look at this thread where I was trying to get help with this issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jason Grim


    Thank you very much for using my plugin. I did write the code to make sure it adds the write lines of code to the wp-config file. I have been getting several questions about the .htaccess file not being created correctly on some servers. I have not had much time to look into it a solution to this problem.

    The define they suggested for you to add to get the generated htaccess information is the only work around I am aware of. That define is to be removed after the install is completed as recommended in the wordpress docs, this is why my plugin doesn’t add it to the config file.

    I will be working on a new version when I get some down time from my clients and workload.

    Thanks again for your time and sorry for your troubles.



    Hey, no problem. Everything’s good now. I just wanted to let you know. I’ll just have to learn more about it, so I can do it myself, unless your new version comes out before my next Multi-Site install. Thanks.

    Plugin Author Jason Grim


    Just an FYI, I have finally taken the time to fix the issues that have been brought up my many of my plugin users. Version 1.5 is out with a complete fix.

    Thanks again addressing this issue,
    Jason Grim


    I had a failure attempting to use this plugin on a 3.1 install that has left me with the problems others report …

    “you will need to empty or remove the network database tables.”

    Can you tell me which network tables exactly it installs and needs to be removed.

    There is nothing in blogs.dir. wp-config.php and htaccess is as it should be.

    The funny thing is, I have done this manually many times and had no problems. I was just exploring the plug to see if I can recommend it to others.

    I use a custom prefix on my tables, not wp_.
    I cannot see any new tables that have been created.

    What should I be looking for to remove in phpmyadmin?


    Plugin Author Jason Grim


    What issues are you exactly having?

    Here are the instructions for uninstalling Mulit-Site

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Enable Multi-Site] Enable Mult-Site only partially worked’ is closed to new replies.