WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Enable Media Replace] Version 2.5.1 is Broken!

[Plugin: Enable Media Replace] Version 2.5.1 is Broken!

  • MikeJarosz

    @mikejarosz

    I installed this plugin before version 2.5.1, and it worked perfectly. Once I installed the latest update of the plugin, it no longer works.

    I get the following error:
    Fatal error: Call to undefined function mime_content_type() in /[edited out for privacy reasons]/wp-content/plugins/enable-media-replace/upload.php on line 32

    http://wordpress.org/extend/plugins/enable-media-replace/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Måns Jonasson

    @mungobbq

    No, the plugin is not broken.

    Yes, the plugin now requires mime_content_type() which is available in PHP versions above 4.3.

    MikeJarosz

    @mikejarosz

    How do I get a PHP version above 4.3? Does it depend on the company I host my server on?

    Plugin Author Måns Jonasson

    @mungobbq

    Yes, it would. But I’ve just uploaded a new version (2.5.2) of the plugin which reverts to the old method if mime_content_type does not exist. Please try it out when you can.

    MikeJarosz

    @mikejarosz

    Works perfectly now, thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Enable Media Replace] Version 2.5.1 is Broken!’ is closed to new replies.