Support » Plugins » [Plugin: Emma Email Signup] I’m getting this error message

Viewing 1 replies (of 1 total)
  • You’ve come across a PHP5 /PHP4 conflict, I bet. I just had this happen with this plugin. The client’s server is running PHP 4.3 and this plugin’s widget has part of it written using PHP5 code.

    What should work is to rewrite these lines (8 through 12):

    class Emma_Email_Signup_Widget extends WP_Widget {
    
    	public function __construct(){
    		parent::__construct( false, $name = __( 'Emma Email Signup', 'emma-email-signup' ) );
    	}

    as this:

    class Emma_Email_Signup_Widget extends WP_Widget {
    
    	var $Emma_Email_Signup_Widget;
    	function __construct(){
    		parent::__construct( false, $name = __( 'Emma Email Signup', 'emma-email-signup' ) );
    	}

    That should fix the problem and allow you to activate the plugin.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Emma Email Signup] I’m getting this error message’ is closed to new replies.