WordPress.org

Support

Support » Plugins and Hacks » Embedly » [Plugin: Embedly] Doesn't seem to embed anything?

[Plugin: Embedly] Doesn't seem to embed anything?

  • Maybe i’m just an idiot, but the example given in the about section of this plugin looks pretty idiot-proof.

    So I’ve tried putting in a hyperlink with the address still attached between the a-tags.

    <a href='http://twitter.com/#!/wired/status/38017736000933889'>http://twitter.com/#!/wired/status/38017736000933889</a>

    But the plug-in doesn’t seem to “embed it”, it just functions like any other hyperlink.

    I’ve checked the plugin settings to make sure that twitter is selected as one of the services I want enabled for embedding, but it doesn’t seem to be doing anything.

    It’s a really neat plugin and I wish it would work.
    Thanks

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Embedly

    @embedly

    There is a minor issue with the way that wordpress handles the links. The Url cannot be in an a tag it needs to be just plan text, otherwise the Embeds code will not pick it up. So it needs to look like:

    http://twitter.com/#!/wired/status/38017736000933889

    We are thinking about ways to handle this, but we don’t want to work outside the WordPress conventions.

    Sean

    I was having the same issue and thinking I must be missing something so thanks very much for posting this query it has helped a lot!!! 🙂

    I am trying also to make it work, with no success.

    I add a link, like the one in the example:

    http://twitter.com/#!/wired/status/38017736000933889

    And the link appears as text.

    I tried with and without visual editor active.

    Plugin Author Embedly

    @embedly

    Hmm, have you turned on auto-embeds in the media admin?

    http://codex.wordpress.org/Settings_Media_SubPanel

    If you mean the “When possible, embed the media content from a URL directly onto the page. For example: links to Flickr and YouTube” setting, yes, it is checked.

    One thing we are using is a plugin to render markdown. But that should be off when I tried with the visual editor on.

    Or perhaps there is a priority conflict?

    The source code of the test gets render thus (text taken from the example given):


    <p>This Embedly lets me embed everything great on the web!</p>
    <p>http://twitpic.com/1owy89</p>

    Is there any documentation for this plug?? I have never been able to get it to work and I’m not able to find any tutorials.

    I think it is time to uninstall and seek an alternate solution.

    I’m also trying to use this plugin but the URL just shows up as text in the post. I’ve followed the recommendations as listed in this thread.

    I was having trouble at first as well, and just FYI for those who may have this problem, you have to make sure you unlink the text so that it does not look like a hyperlink in your editor.

    Then it will work.

    This is not working for me either. I have tried all the tips suggested above and the youtube link still appears as plain text. I have looked at the source code and unlike a previous poster, my theme is not adding any paragraph marks or similar.

    Any other reason why the link would appear as plain text?

    Thanks

    Ditto for me… I followed all the instructions and examples
    All i get is the text of the url in the post.
    dead end.
    now what?

    Plugin Author Embedly

    @embedly

    Sanity check, make sure Auto-embeds are turned on. Admin -> Settings -> Media.

    If this doesn’t fix it, disable the Embedly Plugin and follow the steps for testing the WordPress core embeds – > http://codex.wordpress.org/Embeds

    If WP core embeds do work, please let us know your WP version and user role.

    If WP core embeds do not work for you, you may need to reach out to your hosting provider or WordPress.

    Thanks!

    Sanity check: Yes .. autoembeds turned on.

    Next … disabled embedly …

    Not sure what you mean by “core embeds” but I don’t see any embedded links showing other than straight text

    Not sure why my hosting provider is an issue here. Others seem to be having the same problem. Incidentally I use godaddy. Like them or not they are probably the most widely used hosting provider out there – so if compatibility is an issue (or support for their customers), it’s really in the best interest of the provider.

    As it stands. I’ll just keep embedly deactivated until I hear more from others on this forum that there’s a solution or that it is miraculously working again.

    thanks for the quick response. much appreciated

    Plugin Author Embedly

    @embedly

    Sorry we didn’t get anywhere, here are some general answers to your questions.

    > Core embeds
    WordPress has built in embed functionality into their core product. Embedly extends this by adding 150+ more sites you can embed from. If the core product is not working Embedly will certainly not work for you. (This is why I suggest putting a ticket in with WordPress)

    > Hosting provider
    Clarification , if someone hosts and administers your WordPress for you.

    If you find any solutions, please post.

    Thanks for the suggestions. I am currently disabling plugins to see if any conflict. I also have several other WP installations (including a brand new clean one) that I will check out to see if there is an issue with a theme or anything else. I’ll post back here if I have any success.

    My .02, I’ve had issues from day one.
    My WP Core embeds work great. I take a simple Youtube video, throw it in a post, preview or save, wham…video embeded just fine.

    Hit the Embedly button, paste in same url…churns…churns…nothing.
    Go back the next day, do the same thing, works fine.
    Tested this from 5 different clean installs of WordPress – 1 dedicated server, 2 VPSs, existing shared hosting install and new shared hosting install. Same story each time. When one works, they all work. When one starts churning, they all start churning.

    If there is an issue, divulge. Works great when it embeds, but most of the time, it just doesn’t get that far. Is this going to be fixed, or should we look elsewhere?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Embedly] Doesn't seem to embed anything?’ is closed to new replies.
Skip to toolbar