Support » Plugins and Hacks » [Resolved] [Plugin: Embed PDF] Doesn't work for me

[Resolved] [Plugin: Embed PDF] Doesn't work for me

  • Great idea, but it doesn’t work for me. WordPress 3.1, brand new standard installation. Plugin is active.

    Doesn’t work with standalone line without code or with the code. All that happens is that the URL becomes a link where it’s possible to download the file and view in Acrobat Reader, etc. The URL is valid–it downloads and opens successfully. I’ve tried the code in both the HTML editor view and the Visual editor. It’s not wrapped in any other code.

    I don’t have any fancy plugins enabled that would be obvious candidates for a conflict.


Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Pat Hawks


    Because of the way the plugin detects PDF URLs, the address must end in .pdf

    What is the URL of the document you are trying to embed? Perhaps we can make this work some other way

    Yes, I did have the URL finishing with the PDF of the actual file (eg. http://domainname.com/pdfs/file.pdf )

    Thanks, but I’ve decided to go with another option which does more than I need but works for me. http://wordpress.org/extend/plugins/tgn-embed-everything/

    Plugin Author Pat Hawks


    I’m glad you found something that works for you.

    I believe the problem is just a settings issue.
    In your WordPress dashboard, under the Settings menu, go to Media settings.
    Make sure that Auto-embeds is enabled.

    Sorry this isn’t mentioned in the documentation. Working to fix that right now.

    Hi, thanks for this plugin.
    I have enabled the Auto-embeds in the Settings-Media menu.
    But still it doesn’t work with standalone line without [embed][/embed]shortcode.
    And I have made sure that the URL is on its own line.

    Fyi, I’m using WP 3.1.1
    The plugin works with the [embed][/embed] shortcode.
    But I thought I would like to make it easier for my users & less steps needed (without the need to add the shortcode).

    Please help.
    Thank you.

    Plugin Author Pat Hawks


    yudi_set Please see above. In order for the URL to be auto-detected, it must end with .pdf

    Pat.. I have the same issue.

    Thing is.. it works PERFECT on my test site but not on my live site (and both sites are on different servers BTW)

    I used just the [embed]domainname.com/file.pdf[/embed] on both sites.

    I have the box checked for AUTO EMBED in the media (thank you for reminding to check that)

    Is there something else that we are missing? Both sites are using WP 3.2.1

    Is there a file that needs different permissions to work? Which one would it be?

    I’ll keep searching, but hopefully someone will know the answer soon!


    Plugin Author Pat Hawks


    I’m assuming you include the http:// in the URL

    Can you send me a link to the page? What does it output? Does it just show the text URL, or does the Google Docs Viewer appear without a document?

    I’m really not sure why it would work on a test site but not a live site. Let’s figure this out together.

    Here’s the page it’s on:


    And here’s the link to the working page: (test site)


    It just shows the link to the PDF and not the GOOGLE part.

    I have a few other plugins installed.. but can’t think of any that would interfere..

    Thanks for the help!

    I actually did a cut/paste from the working one to the non-working one, just in case I wrote it incorrectly.

    Very puzzling…

    Plugin Author Pat Hawks


    Both of these pages seem to be set to private. That doesn’t help much.

    Neither page is set to private. But the site probably is. I’ll change it when I get back to my home office.

    Altho I have found another plugin that works, I would still like to figure out why this works on one and not the other.. for others who may be having the same issue. I’ll write when I have set the files viewable and maybe we can figure this out… since others are having similar issues.


    I’m having the same issue. It’s a file ending in “.pdf”, the embed media setting is turned on, and the results are: [removed][/removed]
    Any ideas?

    Never mind – i switched themes and this fixed it. Thanks!

    Plugin Author Pat Hawks


    Ok, I’m very curious. What theme were you using that striped embeds?
    I’d like to look into this.

    Sorry, by ‘theme’, I should have typed ‘template’. I’m kind of new to WP and the terminology escapes me sometimes.

    I was originally (when it didn’t work) using one of our templates that has nothing on it (no html/head/body tag). That template is supposed to be used for pages that are embedded in pages (and so don’t need all those page tags). When I switched to a template that actually used get_header(), get_footer() and all that jazz to get the html markup from our header.php and footer.php files, the plug-in worked great.

    So I’m guessing not having the proper page markup hindered the [embed] ability to do its job? If you want to look into it further, create a template that has absolutely nothing on it (except something displaying the post content), and use that as the template when using the plug in. it just shows up as plain text [embed]http://mydomain/files/filename.pdf[/embed]. If you use a template that uses html/head/body, problem solved.

    Plugin Author Pat Hawks


    Very interesting.
    Glad you got it all worked out 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] [Plugin: Embed PDF] Doesn't work for me’ is closed to new replies.