WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Embed Iframe] problem when switching to PHP5

[Plugin: Embed Iframe] problem when switching to PHP5

  • I switched to PHP5 and my iframe changed size unexpectedly. In the page source the frame was being rendered with the attribute

    style="height:<?=$height?>px;width:<?=$width?>px;"

    I fixed this by changing the shorthand tag in the template file /embed-iframe/view/embediframe/iframe.php to a standard one, i.e.:

    style="height:<?php echo $height ?>px;width:<?php echo $width ?>px;"

    In addition I notice that there are a pile of unneeded functions in the ‘plugin framework’ you’ve included. Are these really all necessary? Can we reduce bloat in future implementations?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’m working on new version of the plugin for which I’ve following fixes planned:
    1) php5 issue
    2) code cleanup
    3) frame width in % instead of px
    Do let me know if you have anything to add here.

    Using WordPress 2.8.1 and am unable to embed http://www.mimio.com/products/index.asp into an iframe. Getting “You don’t have permission to access the requested object. It is either read-protected or not readable by the server. ”

    mebenson

    @mebenson

    I had the same problem as djpeanut, I could not change the size. I replaced the lien of code with the one he gave. It works!

    When will the updated version of this plugin be released? Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Embed Iframe] problem when switching to PHP5’ is closed to new replies.