WordPress.org

Support

Support » How-To and Troubleshooting » [Plugin: Email Users] You do not have sufficient permissions to access this page.

[Plugin: Email Users] You do not have sufficient permissions to access this page.

  • Hi!
    When I want to go to email users I receive this “You do not have sufficient permissions to access this page.” what is happening? I’m the only admin with all right on server.

Viewing 15 replies - 1 through 15 (of 27 total)
  • Probably a bug in the plugin.

    hi i am having the same problem. and it happened after i changed the wordpress table prefix, can someone please help me, i tried switching back to the same prefix it was before but no luck. thanks guys i just dont want to reinstall everything lol damn you wp-security plugin lol

    Any word on this?

    omg no, i been searching all over, it seems that 2.8.1 actually make it stop working as i tried in other installations, and the worse is i cleaned installed the site just to see what was wrong lol fml . the best part is that the plugin is no longer being developed i think GREAT lol

    anyone please please lol i really need this plugin i cant even find another one like it, if anyone know another one that can email users please let me know. thanks

    Yea I have been searching for about 4 hours. No luck.

    Okay so I am not sure whats going on here but I am currently working on getting this fixed. It may take me a little while because I am unfamiliar with programming a plugin for wordpress. I currently have the plugin working but the way i did it is a bit rediculous. I found two pages that were working from the plugin:

    email-users/email_users_options_form.php
    and
    email-users/email_users_overview.php

    I then copied everything from:
    email-users/email_users_group_mail_form.php
    into
    email-users/email_users_options_form.php

    and copied everything from:
    email-users/email_users_send_group_mail.php
    into
    email-users/email_users_overview.php

    In order to get email-users/email_users_group_mail_form.php to open up email-users/email_users_send_group_mail.php when i submit the query I edited the line in email-users/email_users_group_mail_form.php

    <form name=”SendEmail” action=”post-new.php?page=email-users/email_users_send_group_mail.php” method=”post”>

    and changed it to:

    <form name=”SendEmail” action=”post-new.php?page=email-users/email_users_overview.php” method=”post”>

    So now whenever I want to write an email to all my users i have to go to:
    /wp-admin/admin.php?page=email-users/email_users_options_form.php

    Yes i know this is completely screwed up, but I use this plugin on a daily basis and this is going to have to work for now. I am going to try to edit the plugin and see if I can figure out how to make it work properly.

    omg thank you i use it very often too, seems to be working fine the way you did it ps, let us know if you got it working properly but till then THANK YOU 😀

    Yeah, thanks! I don’t use it daily. But I really needed it today and This worked well enough. I’ll be looking out for more a proper fix.

    I’m thinking about going to mailpress. I’ve tried it out. Take a bit of setting up. But it might be the new option.

    hey guys! Any news ?have you guys fixed this problem?

    Mám rovnaky problem bude sa to dat vyriesit ?

    I have the same problem that it will be resolved?

    Since Vincent seems to not be around anymore and his site seems buggered, I’ve updated email-users to fix both the access level issues that have occurred due to the recent security fix in WordPress. I’ve also fixed the missing notify link thing too (using the fix mentioned somewhere else in these forums). You can grab the new version at http://code.google.com/p/email-users/downloads/list

    If anyone notices any problems, please create an issue and I’ll do my best to fix it.

    Hi Scythah,

    Great work fixing the plugin, was driving me made trying to get it to work.

    Do you know if it still works with role manager plugin?

    Regards
    Peter

    I haven’t noticed it stopping working with it. Just keep a backup of the original files and if it does stop working, swap back again and let me know what happens. I’ll see what I can do to fix it.

    Thank you scythah for your efforts. However, when I install and activate the plugin I don’t get the ‘Email’ menu item appearing on my Dashboard menu. The ‘Email Users’ shows up under Settings but no actual menu item. I’m running WP 2.8.2 if that makes a difference. However, this is the same result I got when I rolled back to 2.7.1 and reinstalled. Once it quit working nothing seems to fix it. I’m not a programmer so I’m at a loss.

    Any advice?

    Ok, I’ve made a small change. I can’t see why it’ll make any difference (especially if you are getting the settings page), but give it a try anyway.

    If you can, disable the old version, delete the email-users directory from your plugin folder, upload the new version and activate it. This is just to make sure there are no leftover files from Vincent’s.

    You can see what changes I made in the source code.

    Let me know how you go.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Plugin: Email Users] You do not have sufficient permissions to access this page.’ is closed to new replies.
Skip to toolbar