Support » Plugin: Email Users » [Plugin: Email Users] HTML charcters showing in email

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Mike Walsh


    Off the top of my head, I can’t think of what would cause that to happen. Nothing has changed in the plugin in quite a while now. I assume this has worked for you previously. Any changes to the email configuration on your server? Does the Test Message work correctly?

    I too an having this problem.

    It looks fine in the visual editor, this is what you seen in the received email:

    <p>Can you see my tags?</p>

    [Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum’s parser.]

    Even when I send a test notification to myself, I can see all the html tags. It’s fine whan I just send plain text, but we need to send html formatted emails.

    Any ideas?

    Plugin Author Mike Walsh


    It sounds like your mail header isn’t set correctly. Have you looked at the raw mail headers to make sure they are of the right type?

    It should read something like:

    Content-Type: text/html

    As long as EMail Users is set to use HTML email, it will try to send HTML email. It uses the value from get_bloginfo(‘html_type’) (see this) to get the content type setting from WordPress.

    If the header is correct, then for some reason your mail client isn’t processing it.


    The content type in the raw header was:

    Content-Type: text/plain; charset=”UTF-8″

    Even though I selected HTML from the drop down.

    I was able to change this be adding this snippet to the function.php

    Thanks for pushing me in the right direction.

    Plugin Author Mike Walsh


    Glad you got it working. It is odd that WordPress is returning the content type as plain text. I am not even sure where/how that setting is set but that is what the plugin uses for constructing the header.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Email Users] HTML charcters showing in email’ is closed to new replies.