Support » Plugin: Edit Flow » [Plugin: Edit Flow] Cannot load calendar

  • Resolved blueduck


    Great plug-in. But I’m having an odd problem.

    Edit Flow works as it should for all other (5) writers on our website.

    But when I log in as administrator (I’m the one who installed Edit Flow on the site), although I can view the Calendar, whenever I click on one of the arrows to change the display-date range, I get a blank page that says “Cannot load calendar”. I can adjust the number of weeks that are displayed, but because the arrows don’t work, I’m not able to change the starting date of the calendar display — it’s stuck on April 1.

    When I’m logged in as administrator, the “Cannot load calendar” has happened on 4 different computers, with both IE and Firefox, so it’s not a local computer issue.

    As a test, I set up a new account (with new name) for myself, set the user role to administrator, and the Calendar works fine. It is only with the original administrator account that clicking any of the arrows returns a “Cannot load calendar” page.

    Not a major issue, since I can always log in user my new name, but it is a minor nuisance. BTW, I have deactivated and reactivated Edit Flow, then deleted and reinstalled, but the problem persists.

    Any ideas?



Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Daniel Bachhuber


    Hand Built

    I think it might be a permissions issue, although it’s odd that you can view the calendar to begin with. Can you share some screenshots of before and after, including the URL you’re accessing?

    David Carson


    I’m experiencing a similar issue with the Edit Flow Calendar. I’ll post my experience here instead of starting a new thread if that’s alright because it’s so close to @blueduck‘s issue.

    Summary: If there are multiple post types available in the calendar filter (ex. $supported_post_types > 1) and one of the post types (ex. “posts” or “pages” or “custom post type”) is selected as the filter, then all pagination links including the “Today” link will render the WordPress error message “Cannot load calendar.”

    Here’s a screenshot example where the post type “Pages” is selected in the calendar filter:

    And another screenshot of the error message when the “Today” link/button has been clicked:

    The URL is visible in the address bar of the screenshot, but I’ll paste it just below, too.

    The forward/backward/today links all produce a similar message. Likewise, if any other post type (ex “Posts”) is selected, the same error message appears.

    If the post type filter is reset, all pagination links including the today link work as expected and all is well.

    This error appears to be happening in plain vanilla installs running WordPress 3.5 and WordPress 3.4.2. I tested both locally after experiencing the issue on a live site running WP 3.5. My site runs a bunch of plugins so I tested it on plain installs just to be sure there wasn’t a conflict.

    The “post type” filter looks like it’s the only one with the issue. All other filters (ex. statuses, categories, authors) were working normally.

    I also tried testing it with different roles (as @blueduck and you mentioned) by adding a new administrator and editor. The same error message persisted whether I was logged in as the original administrator, a new administrator or editor. The roles did not appear to affect the error message – my guess is that @blueduck had a post type filter selected without knowing it so the other users/editors and the new profile he set up all worked normally if they didn’t have a post type filter selected.

    Plugin Author Daniel Bachhuber


    Hand Built

    Thanks for the detailed report, David. It was tremendously helpful. I’ve tracked this down and fixed it. The fix will be out in the next release.

    David Carson


    That’s great! Thanks, Daniel.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Edit Flow] Cannot load calendar’ is closed to new replies.