Support » Plugins and Hacks » [Resolved] [Plugin: Easy Recipe] Update problems with recipe display

[Resolved] [Plugin: Easy Recipe] Update problems with recipe display

  • I did the update and now on my recipes it no longer shows the recipe title and some of the formatting is messed up. I did not have any custom formatting.

    When I go in to edit the already published recipe, nothing shows in the “update recipe” box. The ingredients and instructions are blank despite the fact that they are there in the preview.

    Also it had converted fractions to a ? in one of my existing recipes.

    Here is one of my recipes: http://theysmell.com/easy-homemade-tomato-sauce/ the title is missing and when I try to edit it there are no ingredients or instructions listed.

    I have been considering buying the PLUS version, just wanted to make sure everything is working before I do.



Viewing 12 replies - 1 through 12 (of 12 total)
  • I have the same issue plus others that I’ve posted since this release. I’d love to be able to roll back to the previous, working version but I can’t find it. 🙁

    I was looking for a rollback too…

    If you find out, please let me know. I’ll do the same!


    Will do, thanks!

    I also had a new issue pop up when I published a new recipe today: http://theysmell.com/clean-eating-pumpkin-cookies-recipe/

    It’s it duplicating the content when published. On the back end, the ingredients and instructions are sitting OUTSIDE of the recipe box which is empty.

    Plugin Author Jayce53


    Most of the problems are being caused by W3 Total Cache (and perhaps other caching plugins).

    We’ll have an update out in a few hours that gets around it.

    Thank you so much!!!!! I assume the Plus version will have these fixes as well? I’m very interesting in purchasing it.


    Okay, I found the 2.2.7 version of this that I know worked awesome for me! I do love this plugin but this last release was horrific.

    I deleted the entire plugin (and the files for it on my server) – it didn’t delete the recipes (yeah!). I then just browsed to the 2.2.7.zip version of this and installed it.

    Back to a working version – see here: http://www.thekitchenwhisperer.net/2012/09/13/most-awesomest-fajitas-ever/

    The downloads are here: http://wordpress.org/extend/plugins/easyrecipe/download/

    The 2.2.8 version is just a full dump of previous releases (looks like they use Subversion).

    Good luck!

    Thanks! If the update they are releasing doesn’t work for me, I’ll grab that in the morning. BTW, I shared your fajitas recipe and pinned it. Looks great!

    Plugin Author Jayce53


    There’s actually two main problems: the first is that caching plugins can mess up the recipe itself if you re-edit a recipe soon after viewing it and the second is that some people have modified the recipe HTML manually and we no longer recognise it (or only recognise part of it) as a recipe.

    We have a fix for the first problem and we’ll *try* to repair the HTML automatically in the second case. Mostly people seem to be adding extra HTML for section headings in the Ingredients and Instructions. There’s no need to do this (and in fact will break EasyRecipe badly as you’ve seen) – you can get a section heading by prefixing the line with an exclamation mark.

    So you’d use something like:

    1 pound skirt/flank steak or 1 pound boneless chicken breast or 1 pound jumbo shrimp
    1 large yellow onion, sliced
    1 red pepper, sliced
    1 green pepper, sliced
    1/2 tsp cayenne if you want it spicier
    !Additional Stuff
    sour cream, cheese, lettuce, tomatoes, salsa, refried beans…

    “Meat”, Veggies” and “Additional stuff” will be displayed as section headings. If you do it this way you can also tweak the appearance and spacing of the headings using Live Formatting.

    We should have something out that will fix most problems before the end of the weekend.

    Hi Jayce,

    First off, thank you – really, for this plugin as it really is incredible.

    See I initially did the following when I first installed this program eons ago:

    However that never worked from the get go. Thus is why I went to HTML editing. So when I upgraded to this version and all the HTML work I did was stripped, I tried putting it back in however that didn’t work at all. Next I tried a brand new post/recipe and it would work there however if I went to a previous post, removed that recipe (an all text for it in the HTML portion), then added a new one using the formatting you described above it never worked. It actually got worse.

    I do not do anything with the HTML, I use the plugin as a novice user. So hopefully it is just the cache issue for me.


Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] [Plugin: Easy Recipe] Update problems with recipe display’ is closed to new replies.