WordPress.org

Support

Support » Plugins and Hacks » Easy FancyBox » [Resolved] [Plugin: Easy FancyBox] WordPress converting href to full path instead of hash/ID

[Resolved] [Plugin: Easy FancyBox] WordPress converting href to full path instead of hash/ID

  • When I try to use the hidden inline content, the link doesn’t work because WordPress is converting my href=”#fancyboxID” into href=”http://myurl.com/page/#fancyboxID” and it breaks the tie between the link and the element with that id.

    The strange thing is, it works fine on my local machine but not on my host server. In other words, my local instance of WordPress is not converting it to a full path, but BlueHost is. (Both are running WP 3.2 and both are running latest update of this plugin.

    http://wordpress.org/extend/plugins/easy-fancybox/

Viewing 4 replies - 1 through 4 (of 4 total)
  • It turns out that the plugin called Google Analytics for WordPress is responsible for rewriting the href, not wordpress. I have submitted a ticket to their plugin developer.

    Plugin Author RavanH

    @ravanh

    Ok, thanks for reporting this incompatibility between Google Analytics for WordPress and FancyBox (when using it for inline content) … Is it a certain setting in Google Analytics for WordPress that is responsible for this rewriting? I mean, is there any way to switch it off?

    I’ll make a note on it in the FAQ’s / Other Notes…

    I couldn’t find a setting to turn it off, so I just simply found a different plugin for GA and it works fine. The good thing is, there are so many GA plugins to choose from.

    Thanks for the post, been pulling my hair out trying to get this to work.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: Easy FancyBox] WordPress converting href to full path instead of hash/ID’ is closed to new replies.
Skip to toolbar