Support » Plugins and Hacks » [Resolved] [Plugin: Easy FancyBox] Weird Gallery Behavior

[Resolved] [Plugin: Easy FancyBox] Weird Gallery Behavior

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author RavanH


    hi max, i don’t see those arrows on the iphone image… what browser are you using? have you cleared the browser cache?

    oh, and there a a bugfix version .8 online now. please upgrade asap.

    i have upgraded everything. try clicking on the post office image, and the arrows should appear if you hover over the left or right borders. i have confirmed this in Safari and Firefox 4.

    Plugin Author RavanH


    yes, i see some weird stuff there… and although i cannot explain it all, some of it (if not most) stems from the fact that many images have a rel attribute in the source come. some have rel=”tag” others rel=”bookmark” or rel=”lightbox”.

    this triggers fancybox in linking the images with similar rel attributes together in galleries. and there is no way to avoid that, except stripping these rel attributes either by hand or by javascript.

    do you have any idea why it thinks there are multiple images for a post with a single image?

    i was able to get it to work by:

    changing it to “grouped images only”, “one gallery per group”, and article, div.post


    Plugin Author RavanH


    ah! that’s smart. now the existing rel attributes get overwritten by jquery 🙂 did not think of that…

    you can even remove the ‘article’ from there since you are not using an HTML5 template.

    actually, it still seems to be happening. you can see it here: http://www.8bitkid.com/2008/04/21/nyc-comic-con-av-recap/

    Plugin Author RavanH


    That is happening because there is href=”…” twice in there. See your source:

    <a title="Mr. Freeze" href="http://www.8bitkid.com/blog/files/2008/04/img_2319.JPG"><a href="http://www.8bitkid.com/blog/files/2008/04/img_2319.JPG"><img class="alignnone size-medium wp-image-192" title="Mr. Freeze" src="http://www.8bitkid.com/blog/files/2008/04/img_2319-440x587.jpg" alt="" width="440" height="587" /></a><br />

    Edit the post in HTML mode to remove that first <a title="Mr. Freeze" href="http://www.8bitkid.com/blog/files/2008/04/img_2319.JPG"> and that last <br /></a> and it should be fine…

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: Easy FancyBox] Weird Gallery Behavior’ is closed to new replies.