WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Easy FancyBox] Trouble using youtube.com or youtu.be in URL

[Resolved] [Plugin: Easy FancyBox] Trouble using youtube.com or youtu.be in URL

  • Hi,

    I’ve run into trouble using this plugin. It works exactly as documented for me except, it seems, when the link contains the URL’s youtube.com or youtu.be.

    When you click on the link it the overlay appears and the animated circle but that’s it. The video never loads.

    I don’t have a sample available as it’s on a local server so am looking for suggestions on where to look to troubleshoot. I have already tried disabling all other plugins.

    The code I’m trying is from the examples:

    <a href="http://youtu.be/N_tONWXYviM?hd=1&fs=1&autoplay=1" class="fancybox-youtube">View Video</a>

    If I use *any* other URL it works fine. If I use a URL of a page that contains an embedded video then it works fine too. It’s only when I try and link directly to the video.

    ANY/ALL help would be greatly appreciated!

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’m using a new install of Version 1.3.4.8

    Plugin Author RavanH

    @ravanh

    What browser are you using?

    What happens when you open the movie (not the movie page but the movie itself!) directly in the same browser? With the example code the URL would be http://www.youtube.com/v/N_tONWXYviM?hd=1&fs=1&autoplay=1 (notice the youtu.be/ has been replaced with youtube.com/v/)

    Hi RavanH,

    I’m using both Firefox 4 (Mac) and Safari (Mac). The same occurs in both browsers.

    When I visit the movie at http://www.youtube.com/v/N_tONWXYviM?hd=1&fs=1&autoplay=1 it just appears in the browser maximised – as I’d expect.

    I’m at a loss at this stage to explain it.

    Plugin Author RavanH

    @ravanh

    So what happens if you use the code

    <a href="http://www.youtube.com/v/N_tONWXYviM?hd=1&fs=1&autoplay=1" class="fancybox-youtube">View Video</a>

    in your post?

    The same thing occurs. The screen overlay appears and the animated circle appears. That’s it.

    Ok, I’ve uploaded the site to a preview area online. I don’t want to post the address or login details here so will send them directly to you.

    Plugin Author RavanH

    @ravanh

    Got it, and replied. 🙂

    A summary of what I’ve found: a conflict with your theme that force-loads (hard-coded in footer.php) a much older version of FancyBox that does not support Flash movies.

    Plugin Author RavanH

    @ravanh

    Damien, let me know if you did not receive my reply or if you need further help.

    Thanks RavanH,

    I just replied to your email. It’s the weekend and I don’t always check my email when I’m away from the office.

    I’ll see how I go with your recommendations and update the theme to include the current FancyBox version.

    Thank you very much for your help.

    Thanks RavanH. I was able to make resolve the conflicts with the chosen theme and it’s all working well 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] [Plugin: Easy FancyBox] Trouble using youtube.com or youtu.be in URL’ is closed to new replies.