Support » Plugin: Easy FancyBox » [Plugin: Easy FancyBox] Simple Gallery with Fancy Box

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author RavanH


    I’m sorry but I have no idea how FAI Gallery works. Where are the images stored? If they are visible on the Media admin page, they should remain available after deactivating the plugin. If they are stored somewhere else, I have no idea. You’ll have to ask the plugin developer.

    If your images are attached to posts / pages (should be visible on that same Media admin page) then you can simply insert them as gallery via the Add Media button (top left above the post content editor). Choose the option to insert as gallery, set the number of columns to 3 and choose the option to link to file (not attachment page) and Easy FancyBox will kick in automatically 🙂

    Hi It is the insert as gallery via the Add Media button that I am missing whether I insert media from my computer, media library or FIA Gallery, it makes no difference. There is no insert as gallery button. This is why I was looking for the code [gallery ="3" ????] to insert the gallery manually into the page. Please see screenshot.


    Plugin Author RavanH


    OK, I see… I suspect it is the FIA Gallery that replaces the WP internal gallery feature. Disabling that plugin will most likely restore the normal gallery functionality.

    You could try to add the shortcode [gallery link="file"] to your page, but I suspect that will be handled by the FIA Gallery plugin as long as it is activated.

    I did disable the FIA Gallery and as you can see from this screenshot .. there is still no gallery link

    The shortcode .. do I paste it in as you have written it “[gallery link="file"]” or do I replace the text “file” with something?

    Don’t know why these links aren’t showing up:


    Sorry other link doesnt work. Thanks for your time!

    Plugin Author RavanH


    You need to use the code [gallery link="file"] literally. No need to replace anything with anything.

    You should see a tab called Gallery at the top of the Upload/Insert dialog. There, at the bottom you should find the section Gallery Settings with a button “Insert Gallery”.

    If that is not the case, I can only guess there is another plugin running that has disabled this feature. Or even your theme…

    Hi Thanks for following up with this, its been driving me nuts for ages. I have the latest version of WordPress, the latest version of the twenty ten theme and I am using a child theme of it. I have no other plug-in that would interfere with the galleries. My theory is that the photo directories are in the wrong place. Using my FTP program I can see that all my photo directories are still located in wp-content>flagallery>broome-photos
    wp-content>flagallery>buccaneer-archipelago-photos .. etc

    When I disable the FIA Gallery plug-in and visit one of my gallery post

    This is the code I see

    [flagallery gid=4 name=”Horizontal Waterfall”]

    If I replace the above with your supplied code, I get nothing which made me investigate the path to the photos.

    [gallery link="file"]

    These photos also reside in wp-content>uploads>2011>02 .. 03 .. 04 etc, in all their various sizes.

    Maybe if I change the flagallery directory name to just gallery, this might do the trick?


    Really appreciate your help here.

    PS Still not seeing the Gallery tab at the top of the Upload/Insert dialogue box.

    Plugin Author RavanH


    If the FLA Gallery plugin placed your images in its own directory, I am pretty sure WordPress will not be able to find them without the plugin running. Renaming the directory or moving the images to the /uploads/ directory will not help either.

    If you really want to do without the FLA Gallery plugin, you will need to start adding (uploading) each image again through the normal Upload/Insert feature — maybe you need to have the FIA Gallery plugin disabled to even have access to it… In any case, for the Gallery tab to appear, you need to have at least one image attached (in the normal way) to the page/post.

    Please take a look at your Media > Library page. Do you see any images listed there? Are they reported to be “Linked to” any posts or pages?

    Hi .. soooo appreciate this. Screenshot of gallery page now.

    I have inserted 3 new images on the gallery page along with the [gallery link="file"] and a note to users coming to my galleries that the galleries are being upgraded.

    I disabled the FIA gallery plug-in before I inserted the new images but still didnt see the Gallery tab whilst uploading the 3 images to the page.

    I think the reason I am getting the double of these images is that these images already reside in my media library (301 images). I found a folder just called gallery with all my images in their various subfolders representing the individual galleries on my local computer and have uploaded them to the server.

    I cut the individual photo uploads from the gallery page and now have only one copy of these 3 photos but nothing more. I need to understand where wordpress reads the files from in order to be able to understand what is going on?

    When you upload an image to a page/post .. the image source for the thumbnail is from wp-content/uploads/2011/05/acacia-150×150.jpg” but where does fancy box look for the large image? Uploads?

    Now that I have deleted these 3 images from the page why am I still getting the same 3 images only not doubled up and also it has a thumbnail of my featured image included?

    Sorry for being so confused. I am used to normal html and css but am lost with php. Thanks!

    Plugin Author RavanH


    WordPress places all uploads in the directory /wp-content/uploads/…/… etc. But it does something else to keep track of all uploads: there are database entries created just like for posts or pages but this type of the type ‘attachment’. Without the correct database entries, WordPress will ignore files inside the uploads sub-directories.

    What is going on in your case, I cannot say from a distance. It seems a bit messy. No idea if that is related to the FIA Gallery plugin but it sounds like your installation could do with a bit of a clean-up…

    FancyBox does not look for any images from anywhere at all. It is quite passive (read un-obtrusive) in that way. What my plugin does is recognize links to the full size images and then bind FancyBox to those links. That way, when clicking such a link, the image is not opened directly in the browser tab but in a FancyBox modal window. This is independant of what is used as link text or thumbnail image.

    Thank you so much for all your responses. I now have it working and understand that for it to work you need to upload the images to the post/page which attaches the image via the media library (database). I went through all of media library to realise that the other plug-in must have deleted these images from my library, so very laboriously had to upload them again.

    Perhaps for others who may read this post BEWARE plug-ins for galleries unless you want to re-upload hundreds of images when you dont want that plug-in any more. The other thing to note (in my case) was that if you use [gallery link="file"] to display your images, in a gallery type format using fancy box, is that once I had uploaded the images to the media library I had to remove the reference to them on my post, i.e

    <img src=”×150.jpg” alt=”Acacia” title=”Acacia” width=”150″ height=”150″ class=”alignleft size-thumbnail wp-image-2035″ />

    because I ended up with duplicate images.

    Thank you once again, I did not realise I was being helped by the developer. Fantastic plug-in!

    Ps I do have one more small problem, I use a featured image to display a unique header for each page/post and this is showing up as my first thumbnail in my gallery. Is there a way to remove it? I am thinking no as if I delete it from my media library, then it wont show up as my featured image.


    Plugin Author RavanH


    Ps I do have one more small problem, I use a featured image to display a unique header for each page/post and this is showing up as my first thumbnail in my gallery. Is there a way to remove it? I am thinking no as if I delete it from my media library, then it wont show up as my featured image.

    There might be a solution although I have not tested it. You need to break the link between the image and the post. This should prevent it from showing up in the post gallery while still allowing you to use it as featured image.

    As far as I can tell, the only way to break the link between that image and the post/page is to delete it again. This will also remove it as featured image… After you have done that, go to the Media > New file upload page and upload the same image (again, sorry)

    Then open your post for editing again and via the Upload/insert dialog find that image in the Media Library tab. Then hit “Show” and “Use as featured image”.

    Let me know if it works 🙂

    Ho ho ho! Yes that worked! You are so very clever, thanks a million and have a great Xmas!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Easy FancyBox] Simple Gallery with Fancy Box’ is closed to new replies.