Support » Plugin: Easy FancyBox » [Plugin: Easy FancyBox] Not compatible with WordPress 3.3.2

Viewing 15 replies - 1 through 15 (of 15 total)
  • Make that “FancyBox” will work, “Easy FancyBox” and “FancyBox for WordPress” won’t. I’d prefer to use “Easy FancyBox” because it supports multiple file types and advanced look and feel customization.

    Plugin Author RavanH


    Does your theme have the obligatory wp_footer() call in its footer.php file? Does it still not work when you temporarily switch to the default Twenty Eleven theme?

    If you give me a link to your site, I might be able to tell more.

    I am having the same issue –

    Using the Dandelion theme – not sure if the wp_footer call is in footer.php checking now

    This is what I have in footer.php

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    Plugin Author RavanH


    Is there a line with

    <?php wp_footer(); ?>

    just before the closing </body></html> tags? The you’re all good and the problem lies elsewhere.

    Matthew, FancyBox on seems to be working fine. It’s just that both the large ‘thumbnail’ and the original image seem to be unavailable…

    I guess I’m just not clear on where Fancybox is applied – I was hoping to use it to affect the appearance of the lightbox on these portfolio pages:

    To display the title text a bit cleaner and farther from the image – just clean up the whole box appearance because it is currently quite crammed.

    I wasn’t expecting it to turn photos that weren’t before clickable into ones that are – the about page you linked to: – i put the picture back but now it links to a page that does not exist

    Can Easy Fancybox do what I’m looking for or am I barking up the wrong tree ?


    Plugin Author RavanH


    Matthew, your theme has prettyPhoto built in. Adding FancyBox via a plugin like mine will not replace the old lightbox script. Instead, as these two scripts are meant to do similar things, it causes collisions in jQuery. You will either have to keep using prettyPhoto or strip all related code out of the theme…

    Plugin Author RavanH


    twolita, if you’re still there and still need help, let me know.

    Hi RavanH,

    Thanks for your help. My site is

    I checked out my footer.php file and there’s a wp_footer() call:

    <?php wp_footer(); ?>
    	$T_tracking_code = get_option('gpp_tracking_code');
    	if($T_tracking_code != ''){
    		echo stripslashes($T_tracking_code);

    Guessing the other stuff after has to do with the theme I purchased from Graph Paper Press.

    I just did a testβ€”I switched to the default Twenty Eleven theme and activated your plugin (and deactivated the other FancyBox plugin) and your plugin worked.


    But I can’t use Twenty Eleven without a massive rewrite of my site. Not sure what I should do here…

    I switched my site back to my normal theme, but left your plugin activated. Hope that helps!

    Plugin Author RavanH


    Twolita, your theme has an omder version of FancyBox baked into it. Plus, it has a hardcoded call to an older version of the jQuery library. Not very nice for compatibility.

    Using the FancyBox versions together is not possible so you will either have to stick with the older version as provided by the theme (and hope you do not run into issues whith other plugins that need the jQuery library) or surgically remove the FancyBox script from the theme. Which, in your case, looks like it should not be too complicated.

    Here are the steps:
    1. find your themes header.php template file and make a backup of it or make sure that you still have the original zip file so that you can restore your theme if you need to;
    2. now access the Theme Editor from the Administration > Appearance > Editor menu and open that header.php for editing
    3. find the closing tag of the head section, which looks like </head> (notice the difference from the opening tag without the forward slash)
    4. right above that tag, you will see several lines that are responsible for the following code (the lines will look a bit different with some PHP code integrated with the recognizable HTML parts but they should be clearly related)

    <script type="text/javascript" src=""></script>
    <link rel="stylesheet" type="text/css" href="" media="screen" />
    <script type="text/javascript" src=""></script>
    <script type="text/javascript">
      $(document).ready(function() {
    		'width'		      :	600,
    		'height'		      :	650,
    		'overlayOpacity'	 :	'0.4',
    		'overlayColor'		 :	'#000',
    		'hideOnContentClick' :   false,
    		'autoScale'     	 :   false,
       		'transitionIn'		 :   'elastic',
    		'transitionOut'	 :   'elastic',
    		'type'			 :   'iframe'

    5 do you see them? now cut the red wire… πŸ˜‰ … no really I mean it: remove them with mouse-select, right-click and cut …
    (make sure you do NOT cut the </head> tag!)
    6. hit Save and visit your site in another browser tab to see if the changes where successful.

    If unsuccessful, you can go back to the editor and paste the lines back in, hit Save again and you should have the old situation back. Or else restore the original theme files.

    Hope that helps πŸ™‚

    You are my hero.

    That worked. I can’t thank you enough. Sending you a great big smile and a beer if I can find a way to support your plugin. πŸ˜€

    Thank you, thank you, thank you!


    Plugin Author RavanH


    Thanks Anita,

    Your hart warming words of thanks are already a big ego boost πŸ˜€

    Although the PayPal button (on the settings page) or Donate link (on the plugins page) should not be too hard to find πŸ˜‰


    I’m using the Headway theme

    I’ve installed the Easy FancyBox plugin

    When I insert a new thumbnail making sure that the image links to the file URL

    The Fancy box does not appear

    any direction would be much appreciated

    I needed to install the Google Libraries

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Easy FancyBox] Not compatible with WordPress 3.3.2’ is closed to new replies.