Support » Plugin: Easy FancyBox » [Plugin: Easy FancyBox] Media Settings show Warnings; can't customize

  • Resolved JLeksell


    I used Easy FancyBox to create an iframe on a testing server and everything worked fine. However, when I tried to recreate the iframe on our live server, Easy FancyBox doesn’t work.

    When I go into Settings -> Media, all of the options for FancyBox have this warning displayed:

    Warning: Missing argument 1 for easy_fancybox_settings_field() in D:\Inetpub\website\wp-content\plugins\easy-fancybox\easy-fancybox.php on line 240

    Line 240 is just a closing curly bracket.

    This warning appears for: Global settings, Images, PDF, SWF, YouTube, Vimeo, Dailymotion, and iFrames.

    I’m fairly new to WordPress and I haven’t been able to find any reason why this is happening. If it matters, we are using a custom theme designed for us.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author RavanH


    I really cannot explain that message. Do you see it on the admin page or in your error log files?

    Any other plugins running on that site? Does switching them all off solve the issue? And what if you temporarily switch to the WordPress default theme?

    Plugin Author RavanH


    …on line 240

    Sounds like you are using FancyBox version Could you try upgrading to or re-installing the latest or even the development version?

    Line 240 is just a closing curly bracket.

    It should not be… Something went wrong during installation maybe?

    We tried installing various versions to see if any of them worked. We just re-installed the latest and The warnings are still there, but slightly different.

    This is the error message:
    Warning: Missing argument 1 for easy_fancybox_settings_fields() in D:\Inetpub\webroot\wp-content\plugins\easy-fancybox\easy-fancybox.php on line 270

    This is the line of code it is referring to:

    // FancyBox Media Settings Fields
    Line 270 ---> function easy_fancybox_settings_fields($args){
    	switch($args['input']) {
    		case 'multiple':
    		case 'deep':
    			foreach ($args['options'] as $options)
    			echo $args['description'];
    		case 'select':
    			if( !empty($args['label_for']) )
    				echo '<label for="'.$args['label_for'].'">'.$args['title'].'</label> ';
    				echo $args['title'];
    			echo '
    			<select name="'.$args['id'].'" id="'.$args['id'].'">';
    			foreach ($args['options'] as $optionkey => $optionvalue) {
    				$selected = (get_option($args['id'], $args['default']) == $optionkey) ? ' selected="selected"' : '';
    				echo '
    				<option value="'.esc_attr($optionkey).'"'.$selected.'>'.$optionvalue.'</option>';
    			echo '

    This is next to the only options shown: Enable FancyBox for, Links, Overlay, and Window.

    Plugin Author RavanH


    Like I said, I really cannot explain the error. It says the argument $arg is missing but the whole function is called only when that argument exists. So the whole error is completely unexpected, even on (apparently) a Windows server…

    Unless there is something wrong with the WordPress installation. Are there any other weird errors occurring? Anything more meaningful in the server error log files? And what happens when you disable all other plugins and switch to the default theme?

    Plugin Author RavanH


    If there is a possibility to let me take a look in your WordPress admin to see the issue live, please send me the data via the contact for on my site

    Remembered that I never posted our solution to this problem.

    We had to upgrade WordPress to the latest version and that solved all of the errors. We were wary of upgrading at first due to the designers of our template warning us that it could break with an upgrade to WordPress.

    Thanks for taking the time to help RavanH!

    Plugin Author RavanH


    Hi JLeksell, thanks for coming back on this… I never paid attention to the fact you marked version 2.8.5 there. Still, it strikes me as odd but I’ll mark the plugin as incompatible with only 2.9 and up.

    I’m not going to test backward compatibility for those old versions anyway 😉

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Easy FancyBox] Media Settings show Warnings; can't customize’ is closed to new replies.