Support » Plugin: Easy FancyBox » [Plugin: Easy FancyBox] Inline fancybox opening entire page

  • Resolved jen697

    (@jen697)


    Here is my code:

    Download the <a href="#sample_chapter" class="fancybox">Sample Chapter</a>.
    <div style="display:none" class="fancybox-hidden">
       <div id="sample_chapter" style="width:460px;height:380px;">
       content here.
       </div>
    </div>

    My problem is that the link opens the entire page in the fancybox and not the content in the sample_chapter div. I checked the code against what is in your FAQ and it looks okay. I also tried re-saving the Media Settings that enables fancybox for Images and Inline Content. Not sure what I am missing?

    Thanks!

    http://wordpress.org/extend/plugins/easy-fancybox/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author RavanH

    (@ravanh)

    Your code seems correct so there must be something else interfering here. Usually, it is an external click/link tracking plugin that prepends the #sample_chapter inside the href with the full path which results in the link opening the full page inside an iframe.

    If you are running any plugin like one of the many Google Analytics plugins that does click tracking, disable it to see if that changes anything. If it does, then you know you need to look for an option in the plugin settings to disable the feature that is responsible for the issue(try different options). Or switch to another analytics plugin like Google Analyticator which I use on many sites together with FancyBox and even does a nice graph on the Dashboard too 🙂

    jen697

    (@jen697)

    Thanks, you were absolutely right! I have Google Analytics for WordPress by Yoast installed and as soon as I deactivated it, fancybox worked correctly. 🙂 I can’t figure out what settings would fix this though, so I’ll take this over to the analytics plugin’s support forum and see if Yoast knows how to fix it.

    Thanks for all your help! 🙂

    Plugin Author RavanH

    (@ravanh)

    as far as I can remember, it’s something to do with outbound link tracking…

    jen697

    (@jen697)

    Yeah I tried unchecking the box to “Track outbound clicks & downloads” but it didn’t fix it. 🙁 It also doesn’t look like I’ll be getting a response from the Yoast Analytics plugin support forum so I’ll have to find a new plugin I guess.

    Plugin Author RavanH

    (@ravanh)

    Does that plugin provide particular options that you do not find in other GA plugins?

    I can recommend Google Analyticator. It might be simpler that Yoasts plugin but it does the job for normal tracking. Plus it adds a basic graph to your dashboard.

    jen697

    (@jen697)

    I checkout out the Analyticator plugin but a few weeks ago the author said that he will no longer be supporting the plugin, and that Google recently changed their API which he does not have the time to update the plugin support to support the new API. 🙁

    Do you have any other suggestions for good google analytics plugins?

    Plugin Author RavanH

    (@ravanh)

    Hmmm… that’s bad news. Will have to start looking out for an alternative too then. In the mean time, it still seems to be working 🙂

    RavanH i’m having the same problem the inline fancybox is opening the entire page. I have no other plugins enabled on this site.

    Plugin Author RavanH

    (@ravanh)

    @pete make sure you create your link NOT using a full URL but only the #ID… Do you have a link where I can see the issue maybe?

    I am using the same example code as on the plugin page using just #ID, where can I email you a private link?

    Plugin Author RavanH

    (@ravanh)

    You can contact me via http://status301.net/contact-en/

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Easy FancyBox] Inline fancybox opening entire page’ is closed to new replies.