Easy FancyBox
[resolved] Iframe doesn't work on Firefox (13.0.1) (6 posts)

  1. btb84
    Posted 4 years ago #

    Fancy Iframe works correctly on Safari, but when I try to open an Iframe on Firefox i get back that page

    here's how I call the Iframe:

    <a href="<?php the_permalink();?>" class="fancybox-iframe"><?php the_post_thumbnail('thumbnail'); ?></a>

    what's up? any idea?


  2. btb84
    Posted 4 years ago #


    the trouble is SURELY with firefox: if I copy/paste the correct post permalink on the url bar I get back the same error. I'm doing a clean install to solve it.

    that's strange, because the structure of the permalink is the default one!
    do someone of you have ever had the same problem?

  3. RavanH
    Plugin Author

    Posted 4 years ago #

    Got a link?

  4. btb84
    Posted 4 years ago #

    ok, I solved.
    the problem was with another plugin (Role Scoper). It was NOT active, but since it left some settings saved on the WP database, it keeps "something" working even if the same plugin is off.

    there just was a setting on Role Scoper that worked wrong ONLY with firefox, that was not allowed to read some posts.

    definetively, the links on FF were broken NOT because of fancybox.

    thanks, and sorry...
    I wrote here (wrongly) but I could not mind that a plugin would somhow work even if not active and removed from plugin folder!

  5. RavanH
    Plugin Author

    Posted 4 years ago #

    no problem and thanks for sharing :)

    by the way, how did you finally remove those residual rules? maybe others might benefit from your experience (i added a tag for role scoper) ...

  6. btb84
    Posted 4 years ago #

    I just removed from the database all the tables added by Role Scoper, thata should be all the ones with the name ending with "_rs" (wp_groups_rs, wp_role_scope_rs ...)

    by the way, a clean install is better. the point is that if you limit the permission of "Read" of a category/post and then you deactivate the plugin, firefox seems to keep this permission on, even if the plugin is not active. I could not mind this, even because I was working with Safari where all was going ok!

    anyway, it's fixed. being more careful when using plugins is the best way, as always :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic