Support » Plugins and Hacks » [Resolved] [Plugin: Easy FancyBox] IE6/7 issue

[Resolved] [Plugin: Easy FancyBox] IE6/7 issue

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author RavanH


    Can you copy the error here for me? I am sorry to say, I do not have any system running IE6 or IE7 anymore so I cannot verify the error. All browser I work with (IE8+, Opera 10+, FireFox 3.6+, Chrome 7+) show me your page with a working light box overlay…

    But it sounds like IE6/7 has a problem with the included FancyBox 1.3.3 script, which is not developed/maintained by me. I just manage the WP plugin. So my best suggestion for now is two-fold:

    1. Install the previous version 1.3.2 of my plugin from http://downloads.wordpress.org/plugin/easy-fancybox.1.3.2.zip (which includes the FancyBox 1.3.2 script) and see if that one does works in IE6/7

    2. Go the FancyBox support group on http://groups.google.com/group/fancybox and report the issue.

    Hope that helps 🙂

    IE6/7 shows an error “Identifier, string or number expected” in line 38

    33 $('a.fancybox').fancybox({
    34		'autoDetect'	: '',
    35		'titlePosition'	: 'outside',
    36		'transitionIn'	: 'elastic',
    37		'transitionOut'	: 'none',
    38	});

    Have you tried IE8 with compatibility mode? it will emulate IE7.

    Also i have found, that the Overlay-Image stretches vertical in Google Chrome 7+ … this seems to be an issue of the current fancybox version.

    EDIT: I just downgraded to easy-fancybox.1.3.2 and the “stretching isse” on google chrome is gone, but the IE6/7 skript error is the same.

    Plugin Author RavanH


    Ok, thanks for reporting.

    Could you please do a test for me? Edit the file easy-fancybox.php (you can use the WP internal editor or your own simple text editor) and remove that last comma on line 37 (after ‘none’) and see if the error is still there or if it changes.

    Thanks 🙂

    I did a test as described above, but it still didn’t work in IE6/7. Sorry, meanwhile I had to rollback to thickbox to ensure ie6/7 compatibility, which seems not to be supported by fancybox. But thanks a lot for your help.

    Plugin Author RavanH


    No problem. I understand and your reporting and testing so far is much appreciated 🙂

    I have just released version which, among other things, I hope fixes the IE6 error but I understand if you want to stick with thick… If you do get around to try the new version, please let me know if the issue remains. I still have no IE6 or 7 so I’d be very grateful for that 🙂

    In any case, thanks!

    Plugin Author RavanH


    Sorry, I meant

    GREAT!!! I just tried the new Easy Fancybox Version and all my tests on different browsers (IE6/7/8, Firefox, Google Chrome) were positive. NO stretching-image-issue on chrome, no whitepage on ie6/7. PERFECT! Many thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Easy FancyBox] IE6/7 issue’ is closed to new replies.