Support » Plugin: Easy FancyBox » [Plugin: Easy FancyBox] E.Fancybox Options – Confused

  • Resolved Xfactory

    (@xfactory)


    There are a few things I don’t understand with how Easy Fancybox works. I want to display a YouTube video within E.FancyBox. In the FAQ it states;

    This can be forced with class=”fancybox-youtube”, class=”fancybox-swf” or alternatively class=”fancybox-iframe

    My method is to paste the URL in the post, where is the option to add classes to the URL ?

    In the FAQ it mentions you can exclude images;
    —————————————————
    Can I exclude images or other links from auto-attribution?

    Yes. All links with class nofancybox that would normally get auto-enabled, will be excluded from opening in a FancyBox overlay.

    <img src=”url/to/thumbnail.jpg

    —————————————————
    In the images and inline section for E.Fancybox media settings, the first two options I don’t understand, in the FAQ it states that I need to add a class, in the options it states I need a clear field to disabled auto-enabling, followed by the type of formats to detect.

    http://wordpress.org/extend/plugins/easy-fancybox/

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Author RavanH

    (@ravanh)

    Hi X,

    1. The easiest way to get your Youtube links to open in FancyBox is to enable Auto-detection. For the alternative without auto-detection enabled, by adding a class manually, you will need to edit your page/post in the HTML view tab. Find the link wich looks like <a href="...youtube.com/...">link text</a> and append the class attribute like this: <a href="...youtube.com/..." class="fancybox-youtube">link text</a>

    2. For most media links, you can simply check or uncheck the Auto-detect option. Image links are auto-detected by default for JPG, GIF and PNG file types. The field Auto-detect in the Images & Inline content section, can change this. Either change the file type (extension name) or clear the field completely. By clearing the field, auto-detection is disabled.

    Hope it’s a bit clearer now 🙂

    I can’t specify a specific images for Easy Fancy box to ignore ?

    The overlay pops up, but the YouTube video doesn’t appear. I copied the video URL from the YouTube link and it’s not working.

    Plugin Author RavanH

    (@ravanh)

    You can make the plugin ignore a link by giving that link the class “nofancybox”. To do that, open the HTML editor tab and make it look liek this :

    <a href="...url to your media..." class="nofancybox">...text or image...</a>

    Are you using a class for your link or are you using auto-detect? Can you give me a link to the page where your Youtube video is not loading?

    Images I add to a post from Zemanta, are not working with E.FancyBox. Although Zemanta adds all this code;

    <img class=”zemanta-img-inserted zemanta-img-configured” title=”Something – etc etc …” src=”………….” width=”240″ height=”180″ />

    Plugin Author RavanH

    (@ravanh)

    Fancybox does not work on images. It works on LINKS. This means if you link text or image to another image (larger version for example) and someone clicks that link, only then Fancybox will get fired…

    I know, it’s that flickr images have these long URLs and it’s hard to know which part of the URL that E.FancyBox will read, where to cut it off ?

    How does E.FancyBox work with self hosted videos, same thing add a class and URL address ?

    Plugin Author RavanH

    (@ravanh)

    OK, from Flickr… And these URLs end with .jpg or any such extension? And you have the Auto-detect option activated? FancyBox uses the full URL, there is no cutting off and it’s no problem the images are on another domain.

    If these URLs do not end in a recognizable image file extension, the plugin will not be able to detect them. In that case, you will need to give the links the class “fancybox”.

    Self hosted videos can be displayed in FancyBox but it depends on the video format how to approach this. Very common formats (that you know to be supported and playable directly in most visitors browsers) you can link to with class “fancybox-iframe”.

    If they’r SWF files, use class “fancybox-swf”. Other formats need embedding code to be playable in a browser. Use the Inline method for those cases. See “Can I display INLINE content in a FancyBox overlay ?” in the FAQs (near the end) for an example of hidden inline content…

    You can see two examples on http://demo.4visions.nl/easy-fancybox-sandbox/ half way down the page under “Indirect MOV support” and “Indirect OGG support”.

    For better cross-browser compatibility, you could even try to use the well known JW Player to embed the videos in combination with the “hidden inline content” method to show them in FancyBox.

    But the easiest would be to upload them to any of the supported external video providers 😉

    Everything is working, so far so good 🙂 I haven’t tested inline videos yet, hopefully in a day or two.

    I added a image to a post as a thumbnail. Clicking the image, Fancybox won’t display the image at it’s full size which is roughly a 900×900 image ?

    Plugin Author RavanH

    (@ravanh)

    It depends on your screen size and the browser viewport (how large the browsers actual window/tab is where web content is shown)… FancyBox will scale down the image to fit inside the browser viewport. This is done so that the close button on the top right and at least a small part of the overlay so that visitors will always see how they can close the lightbox. So if you open your 900×900 image in FancyBox on a large monitor, it should be visible full size.

    If you upgrade to the latest development version, there will be a new option available, Scale large content down to fit in the browser viewport, that is checked by default. But unchecked, FancyBox should no longer scale images down on smaller screens.

    Is this newer version a beta ? I have the newest version of Easy Fancybox, I don’t see the option for scaling large content ?

    Plugin Author RavanH

    (@ravanh)

    Yes, the development version can be found on the “Other versions” page http://wordpress.org/extend/plugins/easy-fancybox/download/

    I upgraded, I don’t see that option ?

    Plugin Author RavanH

    (@ravanh)

    It should be on Settings > Media under FancyBox. It’s the first option in the Window > Behaviour section…

    There are only three options under Window > Behavior;

    Behavior
    Center while scrolling
    Show the (X) close button
    Show the gallery navigation arrows

    There is no Scale Large Content.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘[Plugin: Easy FancyBox] E.Fancybox Options – Confused’ is closed to new replies.