WordPress.org

Forums

Easy FancyBox
[resolved] Easy-FancyBox resolved ALL links in IE7 (7 posts)

  1. Pavel
    Member
    Posted 3 years ago #

    I used Easy-FancyBox on this website. All links in IE7 resolved by Easy-FancyBox, but need just video link (image on the right sidebar). I found solution on FancyBox support forum, but don't know how use it for Easy-FancyBox plugin. Please, help!
    suppor forum

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    You are trying to open jwplayer in a FancyBox lightbox overlay? And you don't need anything else to show in FancyBox?

    Then start by going to the FancyBox options under Settings > Media > FancyBox and unable it for all media. FancyBox will not work anymore at this point but we'll come back to that later.

    Then, try to get your jwplayer working outside FancyBox. Meaning: how would you normally include a movie in jwplayer on your site? Or can you make it play the movie via a direct link?

    For example, you currently try to show http://miami-immigrationattorney.com/wp-content/themes/pozogoldshtein/jwplayer/video.html?iframe inside an iframe in FancyBox. This might be a good idea but you need to know if the player via that URL works when opened directly. Follow the link and see... To me it does seem to work but maybe you need to change some parameters like http://miami-immigrationattorney.com/wp-content/themes/pozogoldshtein/jwplayer/video.html?id=mediaplayer&file=playlist.xml&plugins=http%3A%2F%2Flp.longtailvideo.com%2F5%2Fflow%2Fflow-2.swf&flow.pluginmode=HYBRID&controlbar.position=over

    If you've got it working outside FancyBox like that, you can then go back Settings > Media and enable the iFrame feature for FancyBox and control its size and options there. Then link from your site to that working URL with class="fancybox-iframe" (like you already have done).

    Alternatively, you might embed any content in jwplayer with custom code directly in your page/sidebar content. If you have a working embedded player, you can then wrap that code inside a div with a unique ID (or example id="my_video_1") and that wrap that div again in another div with class="fancybox-hidden" to hide it from view.

    Then go back to Settings > Media and enable the feature Inline content for FancyBox (same as normal images, you can remove any extension like jpg png gif from the auto-detection box) and link to that content with href="#my_video_1" class="fancybox"...

  3. Pavel
    Member
    Posted 3 years ago #

    Hi RavanH!

    Thanks a lot for fast answer! I just couldn't answer faster (had to go to another country). I tried make all by your First solution and didn't see difference: I have already done this way and all works fine in all browsers, BUT not in IE7 :( I also tried Second solution (with hidden div) but it don't work as it should. You can check it here - seems like there some JS problem in Fancy code. I made step by step as it in instructions, but div didn't shown. What I do wrong? I'm not really cool programmer, sorry :) Can you help me with this? I also think if this "inline" hidden div will be shown - I can place iFrame inside it, m?

    Thank you very much!

  4. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    At this point, there is one thing you need to do before anything else:

    Your theme is loading the Nivo Slider script in the footer, which is fine, but it also loads its own version of the jQuery library there.

    <script type="text/javascript" src="http://miami-immigrationattorney.com/wp-content/themes/pozogoldshtein/script/jquery-1.4.3.min.js"></script>

    This is a problem because the jQuery library (another version) is already called in the header... You need to get rid if this second call. How to do that, depends on how your theme is set up. It might simply be a line in footer.php (if it is, it will be the first line after <!-- SLIDER JS -->... you can delete it) but it might also be done in functions.php. In the last case, it's hard to explain what to look for and how to change it without breaking anything.

    After you got rid of that second jQuery call, FancyBox will behave like it should and you will be closer to finding what works best for you.

  5. Pavel
    Member
    Posted 3 years ago #

    Hi RavanH. Thanks for the suggestion and the time spent! I think we're close to solve this problem, because when I remove second jQuery call - NivoSlider don't work. BUT Fancybox works! I just need to get Fancybox and NivoSlider works together... I found this solution. Can I make that way with easy-fancybox.php plugin file? Or change something to launch it in NoConflict mode?

    BTW, I also found this Post - seems like someone had that problem too.

    Thank you again!

  6. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Yes, it looks like the other thread poster is facing the same issue... I supsect there is a problem between the Nivo Slider and the latest jQuery library version (1.6.1) included in WordPress. fancyBox has no issues with that version but it can also run just fine on the older 1.4.3 version that Nivo Slider seems to need.

    An easy solution therefore might be to replace the /wp-includes/js/jquery/jquery.js file from WordPress with the /wp-content/themes/pozogoldshtein/script/jquery-1.4.3.min.js (rename it to jquery.js and overwrite) ...

  7. Pavel
    Member
    Posted 3 years ago #

    Yes, you right. It's problem between the Nivo Slider and FancyBox plugin. (not included jQuery in WP). After many attempts to run both in the "no-conflict" mode, I finished with it and replaced Nivo Slider with "Nivoo Slider" (based on MooTools) - it has same functions and options. And all working fine now. Maybe it can help somebody. Thank you
    RavanH, you really help me with it!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic