WordPress.org

Forums

Easy FancyBox
[resolved] Easy Fancybox - not displaying images and not closing (22 posts)

  1. madguy000
    Member
    Posted 4 years ago #

  2. RavanH
    Member
    Plugin Author

    Posted 4 years ago #

    Hi Mad, to get around the issue on your site, go to Admin > Settings > Media and set Easing In/Out (both!) to "Swing".

    There seems to be a conflict going on there but I have no idea what. I notice thickbox is referenced in the page source. Do you need that?

  3. madguy000
    Member
    Posted 4 years ago #

    Hi RavanH

    Thanks for the assist - that change in settings solved the issue. I did some digging around and found out that if I change the theme to the default WP 2010, the settings for Easy Fancybox work as-is. I will need to get my devs to upgrade our theme to be compatible to WP 3.0.x.

    This issue is closed as far as I'm concerned - Thanks again!!

    Re: Thickbox, I have the plugin "Thickbox content" activated, that's why I guess thickbox is referenced in the source page.

  4. RavanH
    Member
    Plugin Author

    Posted 4 years ago #

    Do you actually use that plugin at the moment? I would not be surprised if it is Thickbox that interferes with Fancybox. Maybe just switching off the Thickbox plugin will save you some theme dev time ;)

    FancyBox can also display inline content and external pages in an overlay like Thickbox does. Only difference is that with my plugin you do not get that neat TinyMCE toolbar button where you can customize each individual case...

  5. madguy000
    Member
    Posted 4 years ago #

    haven't started using thickbox. I will disable it if it causes issues. Thanks!

  6. jrox10
    Member
    Posted 4 years ago #

    Hi,
    I have installed easy fancybox plugin version 1.3.4.8.
    My wordpress version is 3.1
    My theme is Headlines from WooThemes
    (I hace desactivate the plug-in "Fancybox for wordpress" (just in case...))
    I've tested the plugin in this page:
    http://www.neurorgs.net/197-2/

    And it doen't works¡¡
    I've tried to view a swf file and the code is:

    <p style="text-align: center;">View this flash</p>

    The file path is correct but I only see a blank frame (fancybox popup) . The "x" button works and i can close the popup window
    I've configured :settings->multimedia, to show swf files with autodetect mode switched on

    Any help?
    Thanks a lot¡¡¡
    Jesus

  7. RavanH
    Member
    Plugin Author

    Posted 4 years ago #

    Hi Jesus, it looks like the SWF file that is supposed to be on http://www.neurorgs.net/wp-content/uploads/media/neurorgs.swf is not there... Or cannot be accessed.

  8. jrox10
    Member
    Posted 4 years ago #

    Thanks RavanH
    You're right, i had a misspelling in the file name (sorry)
    At this moment they work fine: image, swf, youtube, inline and iframe
    I have problems to view pdf files
    I've used :
    <p style="text-align: center;">View this pdf</p>

    and it shows up the popup (grey color) but the file does not appears.
    The settings "Enable FancyBox for PDF" and "auto detect" are marked up in the plugin setting page

    In this case i tested the content (pdf file) and it is accesible because I tested with another plugin I used (TGN Embed everything) and it works properly
    [pdf http://www.neurorgs.net/wp-content/uploads/docs/CanonBC-RAE.pdf 900 1200]

    Thanks a lot...your plugin is brilliant¡¡¡
    Jesús

  9. jrox10
    Member
    Posted 4 years ago #

    Sorry RavanH
    I missed the test page : http://www.neurorgs.net/197-2/
    Thanks Jesus

  10. RavanH
    Member
    Plugin Author

    Posted 4 years ago #

    In Opera, Firefox and Chrome it works... Is it IE you are using? Dou you have a PDF plugin installed? What do you see in that browser if you open http://www.neurorgs.net/wp-content/uploads/docs/CanonBC-RAE.pdf directly (not via google docs or anything) ?

    Oh, and is your thread http://wordpress.org/support/topic/easy-fancybox-help¡?replies=1 about the same thing? I cannot open that link (probably because of that reversed exclamation mark in the URL) so cannot answer it...

  11. jrox10
    Member
    Posted 4 years ago #

    Hi Ravan
    I made the test with Chrome (it has de pdf extension) in my Mac
    The same test with firefox produces the downloaded of the file
    With Safari he shows the PDF (out of the popup fancybox)
    In opera he shows the popup with a message at the left of the popup: view the pdf. If you click on this message he open the mac view app for browsing files (pdf,...)

    If I try to open( with the mac) the url : http://www.neurorgs.net/wp-content/uploads/docs/CanonBC-RAE.pdf
    Chrome : open a new tab with the pdf
    Firefox: he downloads the file
    Safari: open a new tab with the pdf
    Opera: : open a window to select the mac preview app...

    I repeat the test in a PC (he has installed adobe reader and probably any plugin he needs to show pdf files ) and he works perfectly on Chrome, IE and Firefox
    Donc for the PC's its OK, but in the Mac the user has to open the file to view or install the correct plugin in the browser.

    Thanks a lot again
    Jesús

    Sorry for the error : easy-fancybox-help its repaeated: its the same question...sorry

  12. RavanH
    Member
    Plugin Author

    Posted 4 years ago #

    The differences you see are related to each browsers settings. I have no control over that. I am searching for an alternative way to embed PDF's in a more cross-browser compatible way but at this point I have no choice but to leave it to the browser to decide how to handle PDF files.

  13. jrox10
    Member
    Posted 4 years ago #

    Thank you very much¡
    It works fine in windows, and in most of mac browser configurations...
    thanks a lot. Jesús

  14. secondtail
    Member
    Posted 3 years ago #

    Aw man, I am glad I found this page. All of a sudden the FancyBoxed images weren't closing and the 'X' wasn't working but I changed to Swing and it was working again.

    It severely freaked me out - maybe you should add it to FAQs in case other people are running into the same issue they can find the fix easier?

  15. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Hi secondtail, there seems to be some conflict with either your theme or other plugins (inserting javascript) going on. These kind of conflicts can have a very wide range of different results, varying from simply not working to minor quirks in behaviour of FancyBox or other scripts. A generic answer like "switch to Swing" would in most cases not have any effect.

    But I'll consider your suggestion and think about some more comprehensive troubleshooting step one can take, and put them in the FAQ's... Or maybe I need to start a forum with all the HOW-TO's, advanced stuff and a troubleshooting guide :)

  16. mdpriority
    Member
    Posted 3 years ago #

    Newbie so do not laugh and not a coder. Where do I find the Fancybox settings? And how much code do I need to show pdfs using FancyBox? I am confused.... sorry

    MDPriority

  17. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    @mdpriority, you can find settings on you Settings > Media admin page. Start with enabling PDF content option and save settings. After that, there will be a new section for your PDF settings. Enable the auto-detect option if you want it all automatic :)

  18. patmatt
    Member
    Posted 3 years ago #

    Help!!!

    Im trying to figure out how to get fancybox to center in the browser window. It's set to far the right.

    Thank you in advance!!

  19. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    patmatt, FancyBox should auto-center... If it doesn't, it might be a CSS or jQuery thing...

    Please consult the fancybox forum on http://groups.google.com/group/fancybox/

  20. atali
    Member
    Posted 3 years ago #

    images not showing in my blog only a white box showing

  21. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    (N?)atali, do you have a link?

  22. atali
    Member
    Posted 3 years ago #

    fixed!
    it's because of wp-minify

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic