WordPress.org

Forums

Easy FancyBox
[resolved] Close Button (X) is behind window for "fancybox-iframe" class (3 posts)

  1. espressodawn
    Member
    Posted 3 years ago #

    Does anyone know why this is? - The close button (X) at upper right is behind the frame. This is when I use the "fancybox-iframe" class. I am embedding a swf with fancybox-iframe because my swf loads a bunch swfs.

    Here's the image

    Here's part of the
    <a class="fancybox-iframe {width:1000, height:730}" href="flash/file.swf">Swf File</a>

    Thanks!
    Dawn

  2. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    You could experiment with embeding the SWF in a proper .html file (complete with header and body etc.) and then give the flash file a wmode="opaque" (or test with 'window' or 'transaprent') property... But it might just boil down to the same thing: The stacking order done by the browser cuases the flash file to be diplayed over the closing button image.

    To allow the close button to show properly, give FancyBox iFrame settings a border of (at least) 10 in the Settings > Media ...

  3. espressodawn
    Member
    Posted 3 years ago #

    Setting border to 10 solved the problem! I'll still experiment with the other options.

    Thanks so much!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic