WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Dynamic Content Gallery] Minor Issue with HTTPS and SSL Certificates

[Plugin: Dynamic Content Gallery] Minor Issue with HTTPS and SSL Certificates

  • I want to report a minor issue involving HTTPS and SSL certificates. Because of an obscure bug involving the way Adobe Flash files display on our site, I put our WordPress media library into the subdomain

    media.oursite.com

    We have an SSL certificate for the main domain

    www​.oursite.com

    but it does not secure the media subdomain. When I enabled SSL on the home page of the site, none of the thumbnails or full-size images would display in the Dynamic Content Gallery (DCG).

    My solution to the problem was to change the media library path to

    www​.oursite.com/media

    so that the media library would be secured by the SSL certificate for the main domain. Now all the thumbnails and full-size images display properly in DCG. I may still need the media subdomain to resolve the Adobe Flash bug, but that’s a separate issue for me now.

    Is there anything that can be done to the plugin so that thumbnails and full-size images always appear on an HTTPS page? I know it’s an obscure problem, but I figured it wouldn’t hurt to ask. 🙂

    Thanks for a great plugin!

    Best wishes,

    Fred Chapman
    [ Signature moderated. ]

    http://wordpress.org/extend/plugins/dynamic-content-gallery-plugin/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author studiograsshopper

    @studiograsshopper

    Fred,

    It might not be a SSL issue, it could be that the root path that the DCG expects has changed, hence the problem.

    What are your settings for DCG Settings > Image Management and DCG Settings > Gallery Method?

    Ade, thanks very much for your reply! Here are some of my settings.

    Image Management: Full URL
    Carousel Thumbnails: Use Post Thumbnails
    Gallery Method: ID Method

    Do you need any additional information?

    Thanks again,

    Fred

    Plugin Author studiograsshopper

    @studiograsshopper

    Hi Fred,

    That info is fine, thanks. It would be useful to see your site.

    I’m wondering if perhaps there is an issue with the SSL after all.

    One suggestion is for you to try the version 4.0 beta of the DCG (go to the plugin’s wp.org page, and browse to the Development version). This version uses the plugins_url() function which means that it *should* handle SSL properly.

    If you don’t want to try that, I really do need to see your site.

    Ade, thanks very much for your follow-up message. It will be a few weeks before I can show you the site. We’re currently preparing the site for launch and can’t make the site available before then for legal reasons. I’ll follow up with you as soon as I can. -Fred

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Dynamic Content Gallery] Minor Issue with HTTPS and SSL Certificates’ is closed to new replies.