Support » Plugin: Duplicator - WordPress Migration Plugin » [Plugin: Duplicator] ZipArchive extension required for compression

  • Resolved yositsitsu

    (@yositsitsu)


    Hi! I am really excited to get this working – it will be a real time saver.

    Package is not created. When checking servers compatability, get this error:

    “Compression: Not installed [-1] (ZipArchive extension required for compression)”

    I guess this is the reason the package is not created – any idea how I can get this fixed? I have a VPS with ZIP installed. (at least when I am in with ssh)

    Thanks!
    Yosi Tsitsu

    http://wordpress.org/extend/plugins/duplicator/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey yositsitsu,

    For some reason it doesn’t seem to be detecting the Zip lib on your server. Did you make sure to compile your PHP setup with “–enable-zip”?

    If your trying to run just the installer then you can run without Zip Support. On the installer screen you will need to check the checkbox ‘Manual Package Extraction’ and manually extract the package before running the installer.

    ON HOSTED SERVERS
    Just contact your hosting provider and tell them you want PHP with Zip support so that the “ZipArchive Class” will work.

    ON YOUR COMPUTER
    If your trying to use the Duplicator on your own computer you will to to make sure the Zip extensions are enabled. Check your php.ini file for the following:

    On Windows: extension=php_zip.dll
    On MAC and Linux: extension=zip.so

    For more details see: http://www.php.net/manual/en/book.zip.php

    Hope this helps!

    Thanks you for your PREMIUM support mate.
    I needed to set up a test env urgently so I did it manually “by the book”

    I am sure this will help others and me the moment they have a similar issue.

    Your help much appreciated.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hi Yositsitsu,

    No problem! With consistent feedback from the community I’m sure we can get this plugin working in many more environments!

    Thanks for the Feedback!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Duplicator] ZipArchive extension required for compression’ is closed to new replies.