Support » Plugin: Duplicator - WordPress Migration Plugin » [Plugin: Duplicator] Fatal error: Allowed memory size

  • Resolved styzer


    Hi all,

    I was able to make it here:
    ✔ Prechecks Completed
    ✔ Package Extracted
    Fatal error: Allowed memory size of 94371840 bytes exhausted (tried to allocate 30123436 bytes) in /home/myserver/mydomain/1/installer.php on line 716

    Hosted on Dreamhost, I don’t understand this.

    Also in the installation instructions, a few things seem to be left unclear:

    1- In installer.php, under NAME, it shows two checkboxes:
    Allow Database Creation
    Allow Table Removal

    I believe this will be the database name I created via MySQL in the control panel of my hosting account, but I can’t be sure (maybe add some notes here for those of us…?). And I have no idea if I should check or uncheck the boxes, or either one.

    Then below you have ADVANCED options. Now I’m really lost.

    Do you have current installation instructions I could find? I understand you have unlimited permutations of cases, but this should be simple enough, right?

    I’m going for my third attempt to install, hoping this time it works…

    Thanks for any help!



Viewing 6 replies - 1 through 6 (of 6 total)
  • No success…

    If you guys could get back to me that would be great!

    Dreamhost being part of your list of compatible hosting, I wonder if you have seen this issue before?



    Plugin Author Cory Lamle


    Hey Styzer,

    This is just a side project and one that we volunteer our time on. We try our best to look at the forums but we usually don’t monitor them every few hours, just and fyi as the posts are only 10 hours apart…

    For now you can edit the following line in the installer.php file. ini_set(‘memory_limit’, ‘1000M’);

    Try something like 2000M.

    The issue your running up against we hope to have addressed in the next version.

    Hope that helps!

    Thanks! Didn’t mean to complain about you guys, just about my own situation and how it does seem that all my efforts go nowhere fast…

    HOWEVER, I would say this: I was able to finally have the site installed. My issue was with a modification that as done to the config.php file. I commented out the code in question and now the site is showing. Also there was a redirect plugin which I’ve disabled.

    Now this is a multisite too, so I have no experience with this type of madness, so I’ll be bringing Duplicator back into my good graces and look to it in the future for simpler site backups. This one here has been heavily edited, so I am NOT blaming it on the plugin (anymore…)

    Regards, and thanks for thinking about these issue for us and with us!


    Plugin Author Cory Lamle


    No Problem!

    Right now the plugin doesn’t support multi-site. We hope to have it in future versions. Right now it’s still a beta plugin…

    FYI for anyone who comes across this same problem.

    I’ve had exactly the same problem and am using Dreamhost. Firstly, I don’t think it’s to do with the plugin, but rather the limited memory space we get on shared Dreamhost accounts. There are two things you can do:

    1. Optimise your WP database. I think it gets unstuck when you are importing a large SQL file. So I suggest using something like WP-Optimize to shrink your database file. This worked first go:

    2. Change your DH domain settings and untick FastCGI and extra web security. This apparently eats up memory resource so disable it for you to run the duplicator install script.

    Hope this works for you.

    Plugin Author Cory Lamle


    Hey Equesta,

    Thanks for posting feedback to your solution!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Duplicator] Fatal error: Allowed memory size’ is closed to new replies.