Support » Plugin: Duplicator - WordPress Migration Plugin » [Plugin: Duplicator] Exclusion of Files not working

  • Resolved sosukeinu


    I’ve been running duplicator for a while now, and no “real” problems to report (only a couple little bugs here or there.) but I’ve noticed my archive getting bigger and bigger. All of the files on my site equal about 150mb, but the archive is always around 600mb. I dug around a little, and found that it was copying the contents of my backup folder, which contained an extra 5 copies of my site. I’ve tried adding the path to this folder in various ways. Sometimes I include the Root path as indicated by duplicator, I’ve tried excluding the root path, and just adding the relative path. I’ve tried an absolute URL. Nothing seems to be working.

    When I used the relative path (excluding the Root Path that duplicator indicates) duplicator says my files are only around 98mb, so I think, “alright, it worked!” but when I actually run the duplicate, the archive is still 600mb.

    Any help would be very much appreciated. Thank you for your time, and for a wonderful plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Cory Lamle


    Hey sosukeinu,

    By default it should exclude the wp-snapshots directory. So when a package is zipped up the wp-snapshots folder with all the subsequent archives should be excluded. Are you running the latest version? If you want to send me your package creation log via our support site at:

    I can take a look and we’ll get the issue ironed out for you…


    It does properly exclude the snapshot directory. I also use BackWPup to perform automated backups. It stores these under the wp-content/backups directory. No matter how I enter this directory to be excluded, I does not exclude it. I will run it again, and send the log early next week. Thank you for taking the time to respond and look into this.

    Ok, just to reiterate. I use BackWPup as a daily auto backup, and use duplicator when I need to move back and forth between development environment and live. Duplicator does exclude the snapshot directory, no problem, but I noticed it was not excluding the BackWPup directory, resulting in duplicates well over 2GB. For now, I simply store my backups somewhere offsite, but I would like to get to the bottom of why it is not excluding directories. my log file is here. Thank you for your time.

    Plugin Author Cory Lamle


    Hey Sosukeinu,

    So just to validate you do have a path saved in the the “Directory Exclusion” list on the package tab of the Options dialog?

    You might try this. In the Options Dialog under the “Directory Exclusion” text input you should see something like:
    Your root directory is: D:/PathToYourWordPress/MyPress

    Have you tried to cut and past this path into the text input and only try something like: D:/PathToYourWordPress/MyPress/wp-content
    Then see if that is excluded?

    If your on MAC or Linux double check that the letter casing is exact. If you want to send me your logs please feel free to do so and send them to the support site listed above in this thread…


    I’m an idiot. There was a space in the path info, removed the space, and all is working well. Thank you very much for your help, and the great plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Duplicator] Exclusion of Files not working’ is closed to new replies.