Support » Plugin: Duplicator - WordPress Migration Plugin » [Plugin: Duplicator] Empty list, no apparent error

  • Resolved almarma



    First, congratulations, looks like a very promising and useful plugin. But it’s not working for me yet: I click on “Create Package”, it ask me to confirm if I want to do it, click on OK, and it keeps working for a while, then the page refresh, and everything is empty.

    Here’s my server info and the debug log I got from the plugin:

    [Log moderated. Please use the pastebin]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Same here.

    WP 3.4
    Duplicator 0.2.9

    Plugin Author Cory Lamle


    Hi almarma and enfueggo,

    Can you repost your logs to the pastebin?


    Aha! Just discovered that PHP is running in Safe Mode, so I’m sure that’s the culprit in my case at least. Just ran Duplicator on another site and package creation worked fine.

    Thanks for responding so quickly, I look forward to using your plugin!

    Plugin Author Cory Lamle


    Excellent! In the up coming version the system checks will be better integrated into the overall workflow…


    Now, with 0.3 it works better, it completes the process, no error in the log file, but my backups list is still empty after finishing and no matter how many times I refresh the Dashboard page, it’s still empty. I’ve manually downloaded the “” file and also the installer.php (which is located in the plugin folder, not in the wp-snapshots folder), and it worked on my local testing server. It’s a really nice plugin, but they only thing I miss is to see the backups on the dashboard to download or delete them easily.

    Thank you for your support!

    Plugin Author Cory Lamle


    Hey alarma,

    Thanks for the feedback! On some system the WordPress DbDelta function has had some issues. To get around this issue go ahead and delete/uninstall the current version of the Duplicator and then re-install a fresh version. This should reset the table schema to work correctly. Once we get through the pre-beta phase of the plugin the table schema should be set in place and the requirement for DbDelta will no longer be needed.

    Let me know how it goes.


    Fantastic!! I did it right now, and now works perfectly!! Snapshot created, downloaded, and used. It’s great. And all the post installation tips about cache and permalinks are really useful. Very useful plugin, specially now that it works :D.

    I tried also to delete a snapshot and no problem at all.

    Thank you! Marked as solved!

    Plugin Author Cory Lamle


    Excellent! Thanks for detailed feedback. I really rely on the community for helping isolate issues as there are 1000’s of permutations of setups that exist out there…


    Hi there

    I’m having the same issue as the original poster with version 3.0.

    my environment is slightly different though as i duplicated a site and installed it on a new server. I then made adjustments to my duplicated site with the view of duplicating this and moving it to another live server. All servers are live and all on on justhosts web hosting. It works seamlessly on version 0.2.9. The only thing that could of caused my issue is that i duplicated the 1st site with 0.2.9 and tried to duplicate it again after changes with 0.3.0.

    is this the expected functionality of the plugin. If I duplicate a site with version 0.2.9 must all subsequent duplicates of that site be duplicated with the same version?
    This may well be usage of your plugin you had not considered as mostly people will create one package and upload that multiple times rather than as I have done essentially create a duplicate of the duplicate.

    Therefore I though I would raise this as in my instance 0.3.0 does not function it does not show as creating any packages and those that it does create in wp-snapshots fail at installation. Server checks and environment all indicate pass or good.

    Plugin Author Cory Lamle


    Hey mjrwebdesign,

    Thanks for the feedback! Right now the installer isn’t bound to the package. Thus 0.2.9 packages may not work nicely, or as in the case you see not at all, with newer installers like 0.3.0. So to answer you question, yes 0.2.9 should to be duplicated with that version to guarantee consistency. The installer might work in some cases but its not guaranteed in these early beta versions. There is a Security update in 0.3.0 which is located on the FAQ page which is highly recommended and you are encouraged to update.

    We are working on a way to bind the installer to the package file so they are keyed together. If your having issues in 0.3 you might try to re-install the plugin.

    Hope this helps!

    Hi lifeinthegrid

    Thanks very much for responding. I did actually try uninstalling and reinstalling duplicator 0.3.0 first through the plugin repository and then after it didn’t work I deleted it and installed it through ftp client and it still didn’t work.

    The only way I could get a package was using 0.2.9. The security isn’t an issue as its developed on a test server and I always delete wp-snapshots (after a successful installation in a new location) anyway.

    One thing I like about 0.2.9 over 0.3.0 is that it tells me the size of the package on the bar as i’m generating it and I don’t have to go to the pre-checks link to find out and then back to create the package. Maybe i’m just lazy but when your are designing and developing all day its sometimes nice to save clicks!

    Good luck with this plugin, its fantastic. I’d really like to see it expand to include quick duplication across a multisite.

    Plugin Author Cory Lamle


    Hey mjrwebdesign,

    I’m working on a solution right now to bind the package to the installer in 0.3.1 per your request, and it’s looking very promising. This will help isolate any issues with compatibility in the installer and package.

    Your concern for the package size in the confirmation dialog I also hope to address in the next version. The goal for the plugin is to keep it as simple and streamlined as possible, so your feedback is very much appreciated.

    The multi-site is a bit more involved and probably won’t be addressed until we can get this version really solid. If you want to submit a support ticket I’ll add you to the Beta testers list and you can help recommend features that will help you use the tool more effectively…

    Thanks again for the feedback!


    working on a WP with plugin version 0.3.1 I get an “all clear” from the server check;
    pass on all SYS-100 … SYS-104, OK/Good/Good on server checks, and PHP SAPI: cgi-fcgi; Pre-Zip Overview: 92.31MB 3,051 Files, 215 Folders ; W3 Total Cache: Cache Directory Not Found


    running the package creator creates an empty list … probably because of:

    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /home/httpd/vhosts/ on line 23

    Warning: file_get_contents( [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /home/httpd/vhosts/ on line 23

    this is something you need to fix at your end if you want to release 😉

    / Peter

    now, after REINSTALLING duplicator it only generates the .sql file but not a snapshot of the site … I’m about to call this a complete failure, not fit for purpose, please advise

    Plugin Author Cory Lamle


    Hey Peter,

    Sorry for any frustration! This error is resolved for the original submitter, and these issues are not always an issue with the source, but the server environments in which it is ran.

    It is very difficult and time consuming to know how a particular server could be configured. With thousands of different configuration possibilities its tough to know how PHP/Apache/Mysql is going to operate on thousands of different hosts. Throw in permissions, OSes, and all the various versions of WordPress and the test matrix is massive. This is why I rely heavily on the community and have a help ticket system if you want me to help you do a deeper dive on your system.

    Most of these issues have to deal with how a host is configured and as I get feedback a vast majority of the issues are fixed. If I tried to make the plugin perfect for every hosting environment it would never get any releases. It is still in a beta stage…

    Here are some suggestions for your particular issue:

    You might try this suggestion for the file_get_contents warning. I’ll see if I can route this to an fwrite, but my feeling is that the process under which PHP runs on your system may not have the correct elevation level to write to this file.

    You can also try the “Developer Version” line found here as I’m continually making fixes as the community brings them in:
    Just click on the “Developer Version” link and download the latest version. If you want an update of what is in it you can check the change log here.

    If your still having issues please feel free submit a help ticket and I can work with you to find out what restrictions might be in effect on your server. 95% of the time its isolating how a server is setup and permission issues.

    Hope that help!

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: Duplicator] Empty list, no apparent error’ is closed to new replies.