Support » Plugin: Duplicate Post » [Plugin: Duplicate Post] Deprecated Notice on Upgrade

  • Resolved sparkweb

    (@sparkweb)


    @lopo, nice work on the plugin lately. I noticed that on my install, going from 2.1 to 2.1.1 when the upgrade function fired I got deprecated warnings about the add_option. Of course now I can’t get it to go again, but it said something like: “there was an error in the way that add_option was called – deprecated since 2.3”. It referenced a line in functions.php. You might look at the deprecated option in http://codex.wordpress.org/Function_Reference/add_option – I think the add_option() in duplicate-post/duplicate-post-admin.php might need a little work.

    But…. you are doing a really nice job on this plugin. I’ve recommended it alongside my own for quite a while and really appreciate the improvements you’ve made to it lately.

    Have you thought about adding a do_action() that other developers could hook on to for other extended functionality with other plugins?

    http://wordpress.org/extend/plugins/duplicate-post/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Lopo

    (@lopo)

    Hi,
    thank you for your help, those lines are among the oldest ones in the plugin so I didn’t see that the parameter (which absolutely un-needed) had become deprecated. Fixed it!

    About you question, I put there two hooks whose documentation is under “Other notes” here. I think this is what you have in mind, feel free to comment about them, as always every suggestion and correction is appreciated!

    Thanks

    Yup, that’s just what I was looking for. Thank you!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Duplicate Post] Deprecated Notice on Upgrade’ is closed to new replies.