WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: DRegister] Custom Fields … Dregister

[Resolved] [Plugin: DRegister] Custom Fields … Dregister

  • I have get the plug in dregister – cos I want more details at registration … it all seems to work, add the fields, says saved. But then makes no difference to the registration page and when I return to the dregister settings – my options have gone. Been driving me mad for hours … any ideas?

    Tried register plus too – but that doesn’t seem to load the full page of options …

    Arghhhhhh … please!?

    http://wordpress.org/extend/plugins/dregister/

Viewing 15 replies - 1 through 15 (of 21 total)
  • Hi, thanks for your contribute.
    Here are some possibilities

    1. Conflict with Register-Plus : have you simultaneously activated both of them ?

    2. Conflict with other plugins : Have you tried activating Dregister as the only plugin of your blog, just to see if it works ?

    3. Corrupt installation : have you tried on a clean WP installation ?

    Let me know you results !

    Just tried on a clean installation with no other plugins installed – still no joy.

    It seems to goes through the correct process – allows me to tick the First and Last name boxes; allows me add customs fields; click save changes and get the message “Changes saved”, but (a) no difference to the registraion page and (b) when reload the Dregister settings page, the previous choices made are not brought back.

    Federico.Lagni
    Member

    @federicolagni

    Hi,
    I’ve the same problem. I’ve just download and installed the DRegister plugin but I’ve exactly the same problem described by jdhfog.

    Before it, I had installed other plugins (as RegisterPlus, etcetera) but I’ve removed alls.

    Hi all,
    I’ve just updated version 1.1 of Dregister, specifically to fix this problem you are having.
    Check it out and please return any improvements.

    P.S. you may have to wait some time for WP repository to show the new version online.

    Version 1.1 is online, but there must be some issue with the SVN.
    If you click Download from the plugin page you manage to get v.1.1 , even if the page still indicates Version 1.0

    Working fine now.

    Federico.Lagni
    Member

    @federicolagni

    Hi Juzaam,
    First of all, thank you for your job.

    I’ve downloaded the latest version and I’ve installed it. I had installed also the Cimy User Extra Fields plugin. Now I’ve deactivated it and I’ve installed DRegister 1.2. After having activate the plugin, I went to Settings–>DRegister but return this warnings:

    ๏ปฟWarning: chmod() [function.chmod]: Operation not permitted in /var/www/web16/web/nameofsite/wp-content/plugins/dregister/dregister.php on line 60

    Warning: chmod() [function.chmod]: Operation not permitted in /var/www/web16/web/nameofsite/wp-content/plugins/dregister/dregister.php on line 75

    Warning: chmod() [function.chmod]: Operation not permitted in /var/www/web16/web/nameofsite/wp-content/plugins/dregister/dregister.php on line 60

    Warning: chmod() [function.chmod]: Operation not permitted in /var/www/web16/web/nameofsite/wp-content/plugins/dregister/dregister.php on line 75

    Warning: chmod() [function.chmod]: Operation not permitted in /var/www/web16/web/nameofsite/wp-content/plugins/dregister/dregister.php on line 60

    …and many others line with the same warning.
    Moreover, if I check, for example, “require first name” and save it, I get this error:


    ERROR: You don't have administrator rights to modify registration options.

    …but I’m logged in as administrator.

    Do you think it could be a problem related do my blogs or DRegister plugin?

    I’ve just tried to deactivate DRegister plugin but I’ve received this error:


    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web16/web/nameofsite/wp-content/plugins/dregister/config/globals.php:8) in /var/www/web16/web/nameofsite/wp-includes/pluggable.php on line 850

    What is your opinion?
    Best regards.

    Hi Federico,
    thanks for your feedback. We really want this plugin to work and your error reporting is very important.

    Before explaining the errors, I anticipate the release of v.1.2.1 to fix the “administrator rights” issue.

    The errors you are experiencing are due to:

    1. AJAX files need to be permission 0755 to work
    2. Updating a plugin sets permission to 0644
    3. Dregister 1.2 tries to fix the issue “chmodding” file permission to 0755
    4. Your host / php.ini settings wont allow PHP to change permissions needed on the file

    The workaround for this first issue is:

    1. Completely delete the plugin directory (wp-content/plugins/dregister)
    2. Download latest Dregister plugin
    3. Upload via FTP the new version to wp-content/plugins/dregister
    4. Eventually CHMOD recursively all files to 0755

    The second issue is a WP version problem in my opinion, due to different roles / capabilities management.

    I tried to fix this releasing v 1.2.1 which should be already available for downloading.

    Hope this helps, if not please return your feedback so we can find other strategies.

    P.S. what WP version are you using?

    Federico.Lagni
    Member

    @federicolagni

    Hi Juzaam,
    First, my WP version is 2.7.

    I’ve redownloaded the plugin and reinstalled it.
    Now, when I go in Settings–>DRegister page (after having uploaded and activated 1.2.1 version), I don’t have any warnings or errors.

    When I check the two default fields (first name and last name) and click on “save changes”, return that the changes has been saved.

    But:
    1) If I reload the DRegister settings page, the options have gone (the changes hasn’t been saved).
    2) If I logout from WP, return this errors:

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/web16/web/nameofsite/wp-content/plugins/dregister/config/globals.php:8) in /var/www/web16/web/nameofsite/wp-login.php on line 255

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/web16/web/nameofsite/wp-content/plugins/dregister/config/globals.php:8) in /var/www/web16/web/nameofsite/wp-login.php on line 267

    …and the same errors in the many other lines.

    …so, the unique method to log-in is delete phisically the directory plugin from FTP.

    This is my simple report.
    Thank you Juzaam.

    Paul Wilson
    Member

    @paul-wilson

    I am still having the same issue3. When I go to swettings, there are no other tabs at the top, like the screen shot on your web site. When I try to adde a custom feild, I get the same error as above. I want to have a register link on my page like the one you have. I deon’t know how to do that ande can’t find the answer.

    You can fix that error yourself by removing the spaces after ?> in plugins/dregister/config/globals.php ๐Ÿ™‚

    Hi everyone,
    thanks for your precious feedback.

    I’m studying the issues with AJAX and WordPress and my 1.2.2 opinion [:)] is that ajax php files should stay in the same directory as the core plugin.

    Regarding this warning:

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web16/web/nameofsite/wp-content/plugins/dregister/config/globals.php:8) in /var/www/web16/web/nameofsite/wp-login.php on line 255

    This should have been fixed as well.

    Grab 1.2.2 as soon as it’s available and please report your experience.

    Federico.Lagni
    Member

    @federicolagni

    Hi Juzaam,
    Now seems to be run and ok! Using this plugin is the best debugging method… then I will notice your if will be other problems.

    Thank you Juzaam!

    I’m glad to hear that ๐Ÿ˜‰
    Please rate the plugin ! ๐Ÿ™‚

    Back in the fray … had a weekend away from a computer for some R&R.

    Juzaam – working just fine now – good work all round – so far not experienced any conflicts either.

    Special thanks to Federico and his analysis – doubt I would of been so persistant with the workload currently under ๐Ÿ™

    If you want a new challenge (?!) … how about a modified user panel so blog administator can re-order the user information page so that the information gathered with Dregister is given appropriate prominance rather than at bottom of list?

    Cheers – jdhfog.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] [Plugin: DRegister] Custom Fields … Dregister’ is closed to new replies.