Support » Plugins and Hacks » Drafts Scheduler » [Plugin: Drafts Scheduler] BUG: Random posting mode only schedules AM hours

  • Hi Jeff,

    I just discovered a bug with version 1.5, but it looks like something that could easily be fixed, hopefully.

    Here’s are the settings I’ve used which present the issue…

    Post Randomly (Surprise Me: Checked)
    Post up to 1 posts per day
    Randomly after: 15:00
    And Before: 20:00

    When my posts are scheduled, they are always scheduled from 3:00AM to 8:00AM, instead of 3pm to 8pm as desired. Any PM hours I set, end up always being scheduled during their equivalent AM periods instead.

    I also tried to change my own time settings in the WordPress settings to 24-hour format, but this did not resolve this issue. It looks like somewhere along the way Drafts Scheduler isn’t resolving the correct AM/PM time period.

    This issue occurs in WordPress 3.1.1 as well as 3.1.2.

    Thanks again for a very handy plug-in!

    Pat

    http://wordpress.org/extend/plugins/drafts-scheduler/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeff Rose

    (@talus)


    Hi Pat:

    You’re the only one who has reported this. I’ve tested and couldn’t replicate. Are you still using the plugin? Is this still happening?

    zauberer

    (@zauberer)


    I had the same issue and I think I found the bug:

    Jeff I think you mixed up time-format:

    instead of setting it to g:i:s (12 hours format)
    just change it to G:i:s (24 hours format)

    I think you only have to change all parts of g:i:s to G:i:s then it works correctly.
    Can you please give me feedback if this is right and if it works correctly now ?

    Plugin Author Jeff Rose

    (@talus)


    Thanks zauberer – it looks like you’re right. I screwed up the time function. I’ll issue a patch for this ASAP.

    zauberer

    (@zauberer)


    I`m glad I could help. Great plugin Jeff!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Drafts Scheduler] BUG: Random posting mode only schedules AM hours’ is closed to new replies.