WordPress.org

Forums

SOPA Blackout Plugin
[resolved] SOPA Blackout Plugin broken (17 posts)

  1. nusi
    Member
    Posted 3 years ago #

    after upgrading to 1.0.4 I got an error saying sthg. like "Syntax-error. Unexpected $end on line 275 in down-against-sopa.php"

    http://wordpress.org/extend/plugins/sopa-blackout-plugin/

  2. Ben Welch-bolen
    Member
    Plugin Author

    Posted 3 years ago #

    Yep I emailed Curtiss and he should fix it very soon.

  3. stevemagruder
    Member
    Posted 3 years ago #

    Yes, this has brought down my entire site.

  4. Ben Welch-bolen
    Member
    Plugin Author

    Posted 3 years ago #

    Should be fixed shortly, just waiting for Curtiss to fix it.

  5. stevemagruder
    Member
    Posted 3 years ago #

    I found a fix...

    In down-against-sopa.php, line 148, add an extra right bracket } to end the function sanitize_sopa_opts.

  6. nusi
    Member
    Posted 3 years ago #

    cool! thanks (i know this kind of errors can be hard to trace)

  7. Curtiss Grymala
    Member
    Plugin Author

    Posted 3 years ago #

    When I was committing some development changes, somehow my in-progress version got marked as the new stable version. I'll be committing a fix in about 30 minutes. Sorry for the issues.

  8. Curtiss Grymala
    Member
    Plugin Author

    Posted 3 years ago #

    I've just committed the new version that should be stable again. It should be available in a few minutes.

    I apologize for any inconvenience. It turns out that there was a single extra character at the beginning of the readme file that caused the WordPress plugin repository to ignore the readme altogether and serve up my development version instead of the current stable version.

  9. P3air
    Member
    Posted 3 years ago #

    still broken

  10. Ben Welch-bolen
    Member
    Plugin Author

    Posted 3 years ago #

    Everything is working fine when I tested, I also had two other people test to make sure. Can you tell me in more detail what problem you are having?

  11. stevemagruder
    Member
    Posted 3 years ago #

    P3air, if your site is down because of the problem, do an edit per my instruction above, and then go into your site and upgrade to the new version of this plugin.

  12. P3air
    Member
    Posted 3 years ago #

    plugin doesn't finish to install - it stops after downloading in the installation process.

  13. Ben Welch-bolen
    Member
    Plugin Author

    Posted 3 years ago #

    Can you explain a little further? I just tested on two of my websites the upgrade and it worked fine.

    Are you using the update in the wp backend? Or downloading and installing manually?

    Thanks, Ben

  14. Curtiss Grymala
    Member
    Plugin Author

    Posted 3 years ago #

    @P3air - That sounds like a deeper issue with WordPress, rather than a plugin-specific issue. Are you able to install any other plugins using the same method you're using to install this plugin? Thanks.

  15. P3air
    Member
    Posted 3 years ago #

    I don't have the resources to dig in deeper this week. Plugin just stops after downloading and doesn't make the final jump into 'installed plugins' universe.

    We run +60 plugins on our site and they all are just doing well, except for this one.

    @ Curtis: please don't give me the run-around. Our installation is just fine. If you want to do some investigation I have disabled site compression so you can have a relative clear php source:

    http://www.p3air.com

  16. Curtiss Grymala
    Member
    Plugin Author

    Posted 3 years ago #

    @P3air - I am not trying to give any kind of run-around or skirt any issues; I am just stating what has been the case in 99% of the situations I have encountered like the one you're describing.

    I apologize for the issues you are experiencing. If you don't want to dig any further into the issue, that's your prerogative. However, if you would like to look us to continue helping you with the issue, please let us know the answers to these questions, so we can attempt to replicate the problem on our end:

    1. Are you attempting to upgrade an existing instance of this plugin, or are you trying to install it fresh?
    2. Are you installing the plugin manually (through FTP) or are you installing it through the WordPress backend?
    3. What version of WordPress are you running?

    Thank you.

  17. plugin doesn't finish to install - it stops after downloading in the installation process.

    @P3air - That's not a plugin issue with ONE plugin.

    Go in via FTP.
    DELETE the wp-content/plugins/<pluginname> folder if there.
    DELETE anything in wp-content/upgrades.

    Try again. If it still fails, please make a new topic for yourself. THIS topic is for Curtis to help fix the $end error. Which I believe he did, so I'm flagging this RESOLVED.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SOPA Blackout Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic