Support » Plugins and Hacks » [Resolved] [Plugin: Domain Theme] Cannot load domainTheme.php

[Resolved] [Plugin: Domain Theme] Cannot load domainTheme.php

  • There is an issue in version 1.0 that requires that domainTheme.php be placed directly into the plugins folder (not a subfolder) per the instructions, otherwise WP will not be able to locate the plugin and you will receive an error:

    Cannot load domainTheme.php

    I will include an update in version 1.0.1 to be more forgiving!



Viewing 14 replies - 1 through 14 (of 14 total)
  • More importantly, there’s an error with the unserialize function on line 51:

    Warning: unserialize() expects parameter 1 to be string, array given in /home/upwithsk/public_html/blog/wp-content/plugins/domain-theme/domainTheme.php on line 51

    // Load domain option settings
    $this->options = unserialize(get_option("domainTheme_options"));

    This error prevents options from being saved, and generally breaks the admin area.

    Hmmm, this topic is marked as resolved, but i just installed the plugin and the error still exists …

    is there an easy fix for this?

    There is. Replace this line

    $this->options = unserialize(get_option("domainTheme_options"));


    $options = get_option("domainTheme_options");
    	$this->options = unserialize($options);
    } else {
    	$this->options = array();

    I cannot get this plugin to work properly.

    The options are not saved.

    Can anyone fix this??

    Thanks Dominik, I should have read your post first! Just wanted to let everyone know that I’ve updated the plugin with the latest fix and also resolved the issue with the plugin appearing in its own sub-folder.

    Thanks to Shrijver too for pointing out the SERVER_NAME versus HTTP_HOST issue that some users may experience. The default is now HTTP_HOST. Also included in the readme is a special note to All-In-One SEO users to blank out your Home title which would normally overwrite Domain Theme’s settings.

    These fixes are now in version 1.1.




    I get these errors after adding one domain name this one on top of my dashboard
    Warning: Invalid argument supplied for foreach() in path to plugin/wp-content/plugins/domain-theme/domainTheme.php on line 70 and this one on the domain theme settings page
    Warning: Invalid argument supplied for foreach() path to plugin/wp-content/plugins/domain-theme/domainTheme.php on line 300
    so I deactivated it again , seems it still doesn’t work well

    Grrr… its broken for 2.6.1, I’ll look into it asap.

    I’ve fixed it for 2.6.1 and you can find the latest version at http://www.virtuosoft.net/domaintheme

    I’ll be sure to update it here shortly. Hope this helps everyone out!


    A new version 1.3 has been released that fixes data incompatibility with vesion 2.6 to 2.6.1 migration. I will update WordPress shortly.

    Side question – when you say “Modify your DNS settings to point your domain name(s) to the same server.” all that means is to give the new domain you want to add the same nameserver info as the default domain where the plugin is installed? Correct?

    The reason I ask is bc its not working but it might just be the DNS taking its sweet time to resolve….

    thanks in advance…

    Its still not working so its not the DNS taking its sweet time to resolve… do I have to actually add the additional domain as add on domain in cpanel? Any help from anyone is appreciated…

    I have the same problem as nando99 – not quite sure what else to do besides pointing the name servers – thanks for your help!!!

    I believe Nando had http:// in his domain definition, and/or need to use the SERVERNAME vs HTTPHOST definition (see the last item in the notes).

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] [Plugin: Domain Theme] Cannot load domainTheme.php’ is closed to new replies.