Support » Plugin: FAQ Block » Plugin doesn’t work with WP 5.0

  • Resolved lstep

    (@lstep)


    Was using with WP 4.9, and then upgraded to the newly released 5.0, which gave this exception:

    Fatal error: Uncaught Error: Call to undefined function gutenberg_get_jed_locale_data() in /var/www/betatest/wordpress/wp-content/plugins/faq-block/faq-block.php:55 Stack trace: #0 /var/www/betatest/wordpress/wp-includes/class-wp-hook.php(286): MeowApps_FAQ_Block->admin_init('') #1 /var/www/betatest/wordpress/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /var/www/betatest/wordpress/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #3 /var/www/betatest/wordpress/wp-admin/admin.php(156): do_action('admin_init') #4 /var/www/betatest/wordpress/wp-admin/plugins.php(10): require_once('/var/www/betate...') #5 {main} thrown in /var/www/betatest/wordpress/wp-content/plugins/faq-block/faq-block.php on line 55

    I had to remove the plugin by hand (rm) to allow me to access again to WP. Trying to install it from scratch also fails.

Viewing 2 replies - 1 through 2 (of 2 total)
  • In the new core, gutenberg_get_jed_locale_data() is now wp_get_jed_locale_data()

    Plugin Author Jordy Meow

    (@tigroumeow)

    Hello @lstep,

    I am so sorry about this bug! I have just fixed it and pushed a new version, it is now 1.0.2. Please try it, it should work. I am using the FAQ Block on many websites myself so it should always work, I was about to update all those websites to WordPress 5 thinking that all my plugins were compatible while in fact, this one was not. So again, I am sorry, and also, thank you for telling me.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin doesn’t work with WP 5.0’ is closed to new replies.