Support » Plugin: PayPal for WooCommerce » Plugin doesnt work on my website

  • Resolved csandreas1

    (@csandreas1)


    I have enabled paypal and Braintree options, added a sandbox account for paypal but the plugin doesn’t work. It only shows the paypal button on the top of the page but not the payment options on the checkout page.

    I get this: Sorry, it seems that there are no available payment methods for your state. Please contact us if you require assistance or wish to make alternate arrangements.

    • This topic was modified 6 months ago by  csandreas1.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Oliver

    (@angelleyesupport)

    HI @csandreas1, Sorry for the delay in response , Please go to express checkout settings and in checkout display settings , make sure you select option saying Both top and regular gateway list and then you will see Express checkout option in the regular gateway list.

    Please give that a shot and let me know if you still see any trouble.
    Thanks!

    It should be the default option anyway.

    On my one website the Paypal Express now appears but when i click the checkout button it redirects to the cart page.

    On my 2 website the express checkout does not appear (i have chosen top and bottom)

    Braintree payments option is enabled to both websites but appear to none of both of my websites..

    Website 1
    Website 2

    Shopping zone is Europe

    • This reply was modified 5 months, 4 weeks ago by  csandreas1.
    • This reply was modified 5 months, 4 weeks ago by  csandreas1.
    • This reply was modified 5 months, 4 weeks ago by  csandreas1.
    • This reply was modified 5 months, 4 weeks ago by  csandreas1.

    Can i get a response? Why those issues happen?

    Also when i click checkout it redirects to the cart page and i get this:

    10002 – Security header is not valid

    • This reply was modified 5 months, 3 weeks ago by  csandreas1.
    Plugin Contributor Oliver

    (@angelleyesupport)

    Hi @csandreas1, I’m really sorry for delay in getting back to you. We were little over swamped lately which led the delays in responses. Please accept my sincere apologies.

    The redirection issue seems to be due to some cache or CDN issues. I see that you have cloudflare activated on both of your site, that would be a main reason for such behavior.

    Can you please go ahead , remove any caches, then enable development mode in cloudflare and then give it another shot?

    The error 10002 – Security header is not valid Simply means that your credentials are not correct, Please double check and add correct APi credentials and this error will go away. Here is a good link why 10002 error happens, please read that as well.

    Thanks!

    I have paused Cloudflare, deactivated caching plugin and Clearfy but still the issue persists. Also i am using sandbox account.

    Plugin Contributor angelleye

    (@angelleye)

    @csandreas1,

    As @angelleyesupport mentioned, this error means that your API credentials are incorrect. Please double check the values themselves, and also make sure you are not setting live credentials in the sandbox fields or vice-versa. One way or another those credentials must be incorrect if you are getting a security header error.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.