Support » Plugin: File Away » Plugin doesn’t work on Flywheel

  • Recently migrated this site from SiteGround to Flywheel. FileAway no longer works. We have tried disabling all other plugins, and switching to default 2019 theme, no joy. Files for the URL above are in the following directory:

    [web root]/library/scholarly

    Here is the shortcode used on this page:

    [fileaway type=”table” filenamelabel=”scholarly” metadata=”database” icons=”none” mod=”no” size=”no” stats=”false” only=”.pdf”]

    It worked perfectly before the migration to Flywheel, but now it does not.

    In the FileAway configuration, the base directory for all paths is shown as /wordpress/ – I’m not clear if that’s just your shorthand for “whatever the base directory is”?

    Flywheel has a bit of an odd setup, in which the core WP files are not in the base directory. There is a symlink in the base directory – .wordpress – which I believe points to the location of the core files. I suspect this is at the root of our problem…

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author thomstark

    (@thomstark)

    First, make sure after your migration that you’ve gone to File Away settings and clicked on “Save Settings”. This won’t fix your issue but it’s imperative whenever you migrate.

    Second, open up wp-content/plugins/file-away/lib/cls/class.fileaway_utility.php

    Go to lines 635-636 (the 2nd and 3rd lines of the realpath function).

    Comment those lines out and insert two new lines below them. The lines should look like this:

    
    //$check1 = str_replace('\\','/',realpath($base1.$path));
    //$check2 = str_replace('\\','/',realpath($base2.$path));				
    $check1 = self::replacefirst(str_replace('\\','/',realpath($base1.$path)), rtrim(str_replace('\\','/',realpath($base1)),'/').'/', rtrim(str_replace('\\','/',$base1),'/').'/');
    $check2 = self::replacefirst(str_replace('\\','/',realpath($base2.$path)), rtrim(str_replace('\\','/',realpath($base2)),'/').'/', rtrim(str_replace('\\','/',$base2),'/').'/');
    

    Save the file, then reload your page where your fileaway shortcode is and tell me if that works.

    Thanks for the prompt response! Unfortunately, that did not resolve our issue. If you look at the previously-linked page, nothing has changed. I re-saved FileAway settings, re-saved the page in question, cleared the cache… nothing.

    Plugin Author thomstark

    (@thomstark)

    Further troubleshooting will be a bit more complex. Please contact me at fileaway.plugin@gmail.com and reference Flywheel in the subject line. I would like to figure this one out. Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.