Support » Plugin: Head & Footer Code » Plugin doesn’t work in the desktop view

  • Resolved carmenrahe


    I installed the plugin and inserted the Facebook messenger plugin’ code in the Head. I want to show up Facebook messenger at the home page, but it only appears on the mobile version.

    I have no idea about html so I do not know which is the problem.

    Thank you so much in advance.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi @carmenrahe,

    Please provide couple more details:

    1. Where you exactly included FB Messenger code (take full back-end page screenshot and provide it here)
    2. If you disable caching plugin, does FB Messenger appear on Desktop?
    3. Do you use some specific template for homepage? Do you have messenger on other pages on desktop?
    4. Please enable debugging in WordPress as described in this article and get back to me so I can check does your template process wp_head hook


    Hi @urkekg,

    Sorry for answering late. I disabled caching plugin (WP Fastest Chache) and now it works! I am using Pinnacle template for my site. I attach a screenshot so you can see where exactly I included FB Messenger code.

    Many thanks for your quick support!


    @carmenrahe If you need a reliable caching solution I recommend the paid premium caching plugin WP ROcket. I use on all my sites only this one, after many tests with other free and also with other paid caching plugins. Easy to clear all cache and works with CloudFlare too!

    Wp Rocket works also with ManyChat MSG code no issues on our sites.

    You have a settings area in this plugin where you can exclude certain files like CSS or other JS [if needed] when aggressively minifying, so it makes it easy to keep the functionality.

    Also, on a per-page and per-post you can set caching elements to turn off if need be.

    And to preload, prefetch to further speed up page load, aside from MC scripts doing their bit assync.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Plugin doesn’t work in the desktop view’ is closed to new replies.