Support » Plugin: User Role Editor » Plugin Doesn't show Up

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Vladimir Garagulya

    (@shinephp)

    Delete wp-content/plugins/user-role-editor folder and try to reinstall “User Role Editor” from the scratch.

    I’m having the same issue. I deleted the folder and reinstalled from scratch, but it still won’t show up in my list of installed plugins or the left menu.

    Edit:
    Just figured out that it’s because I’ve changed my own role with the plugin. Even though I copied the Administrator role to create my custom role, it says that I do not have sufficient permissions when I go to http://www.MYSITE.com/users.php?page=users-user-role-editor.php

    I actually have to log in with under a user that is an Administrator to be able to see the plugin.

    Can this be fixed so that I can see the plugin when I’m logged into a user that has a custom role?

    Plugin Author Vladimir Garagulya

    (@shinephp)

    Do you use multi-site WordPress installation? In case it is multi site, did you check under super-admin?

    Just edited my comment to include more info.

    Plugin Author Vladimir Garagulya

    (@shinephp)

    Add new capability, e.g. ‘ure-admin’, then turn on this capability for “administrator” role and for other role you wish to have access to User Role Editor.

    After that go to /includes/define-constants.php and replace “administrator” role at line 20

    define('URE_KEY_CAPABILITY', 'administrator');

    Thanks! Will try to this out.

    And thank you for replying so quickly too. 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Plugin Doesn't show Up’ is closed to new replies.