Support » Plugin: Relevanssi - A Better Search » Plugin doesnt show hightligts and proper excerpts

  • Resolved Serega1

    (@serega1)


    Good day!
    Thank you for your plugin. I use it for a couple of years, and everything works fine.
    Today I updated version to the last one i noticed that plugin doesn’t show hightligts in the search results. Also it doest show custom excerpts (excerpts with a part of the post, containing found text). It shows wordpress’s post excerpts (without found words).

    I rolled version back, changed another versions and figured out that it works correct till version 4.1.4. From the version 4.2 and further plugin doesn’t show hightligts in the results.

    I dont have any Relevanssi filters and snippets in functions.php.

    So, may be you can fix it, i can provide any additional info and logs you need.

    Thank you!

    • This topic was modified 10 months ago by Serega1.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mikko Saari

    (@msaari)

    Version 4.2 introduced a major bug fix in the excerpt-creation, so if anything, it should work better.

    Whether or not the excerpts are shown depends on the theme, so I’d start by making sure that the theme is co-operating. If you use the Relevanssi admin search (Dashboard > Admmin search), does that show the correct excerpts and highlights? If it does, then the problem is in your theme; if it doesn’t, the problem is in Relevanssi, and the next step is to check that the Relevanssi excerpt and highlighting settings are correct.

    Which is the case here?

    Serega1

    (@serega1)

    I switched ON admin search. Nothing’s changed. Excerpts are still without highlights, and always are the first paragraph of the post, not search excerpts nor post excerpts.
    Theme shows search results by the_excerpt(); function, nothing special…

    UPD:
    Hm… I’ve fix it.
    By checking checkbox
    “Uncheck this if you use non-ASCII characters”

    Instruction says:
    If you use non-ASCII characters (like Cyrillic alphabet) and the highlights don’t work, unchecking this option may make the highlights work

    My site is in Russian, with exactly “non-ASCII characters (like Cyrillic alphabet)“. But in my case it works complitely opposite. If checkbox is checked – highlights work. If checkbox is unchecked – they don’t.

    Maybe it has something to do with UTF-8. Maybe because of something else… Anyway everything’s working now, problem is solved.

    If you think it’s a bug – I can provide any info and you can fix in in the future.
    Thank you

    Plugin Author Mikko Saari

    (@msaari)

    Yes, if you are using UTF-8, you don’t need to uncheck the box, and unchecking it may be a problem. I guess I need to improve the instructions there. The box is required, if you use Cyrillic alphabet with some other character set.

    (Also, I didn’t mean turning on the admin search setting; I generally don’t recommend that. I meant the admin search, which can be found under Dashboard > Admin search. It’s a 100% pure Relevanssi search, and almost always useful when debugging problems.)

    Serega1

    (@serega1)

    yeah, probably you need to change the instruction, just to prevent questions like mine. Because UTF-8 now is a standart, and used by default. Or that checkbox for non-english languages might be checked as default. Or Relevanssi can determine character set by itself…

    Thank you a lot for your work!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plugin doesnt show hightligts and proper excerpts’ is closed to new replies.