Support » Plugin: Easy Modal » Plugin doesn't seem to do anything at all

  • Installed your plugin (the free version – thank you). So far, it doesn’t seem to do anything at all.

    My experience:

    After adding your plugin, I’ve activated then looked through your menus (Modals, Theme, Settings, Help). I then clicked on the Modals menu. This shows me a page with the button Add New. I click on Add New and I get 3 tabs: General, Options, Examples and a button that says Save Settings. I click on General and nothing happens. The same for Options and on Examples. So I click on Save Settings. Something happens but I can’t see any results. So I try listing my Modals from the menu again. This time the page shows me that I have one modal. It is numbered 1 and has the class e-Modal1 and the name Change_me. When I click on the number or the class or the name I go back to seeing a page with 3 tabs: General, Options and Examples which again do nothing when I click on them.

    I’ve read through your plugin page on WP and your web site but I don’t see anything that shows me how to get started. There seems to be a lot of people with malformed themes missing wp_head and wp_footer and with old version of JS. I can see that my theme has both of these routines and I have no idea how to update my JS (or how I would determine if that was even needed). I’ve reached the “Delete” plugin step. Before I do that, I’m hoping you can suggest something. What am I doing wrong?

    BTW I’ve added the <a href="#" class="eModal-1">Open Modal</a> to my home page and I can see the link but as expected, it does nothing when I click on it.

    My web site is under development so I can’t open it up to you to see. I’m using a child theme of the Customizr theme and a bunch of other plugins. I’m using the latest Chrome.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author danieliser


    Hey dccharron,

    this sounds like a javascript error but if your using the latest version i would have to say that we have already resolved them and havent added anything new that would have broken it.

    Best guess would be that either
    A) another plugin is loading JS on all admin pages ( usually a bad thing, should only load on its own pages ) and either this script has a coding error or it is trying to initialize on elements that arent on the page since its the wrong page.

    B) there is another plugin causing a conflict with easy modal and creating an error.

    Basically the only reason the tabs dont show is because JS didnt finish executing which is what happens when JS Errors occur.

    Can you open your browsers console in developer tools and reload the page. You should get the error message there which will help me find the problem for you. or send me temp admin access so i can troubleshoot quickly.

    danieliser at

    Thanks for the quick response.

    I tried deactivating any plugin that might affect the WP dashboard (except one – see below) but this had no effect.

    As for opening my browsers console in “developers” tools, I wasn’t sure what you meant. So I tried a few things:


    I checked in Firebug console for errors. There was one that came up on the Modals page.

    TypeError: td is null

    and on the right it said admin...._id=new (line 580)
    I found it interesting that every few seconds, on the Firebug console, further notifications are coming that relate to loading ajax-admin.php but this is not an error just informational message with a label of POST.

    In Chrome:

    I turned on the Developers Tools and refreshed the Modals page. A warning (triangle with exclamation mark). When I clicked on it, it pointed me to:

    event.returnValue is deprecated. Please use the standard event.preventDefault()instead.

    that seemed to be pointing to something called “load-scripts.php” followed by lots of ? parameters (it won’t let me copy and paste them). I assume that this is a core WP script.

    I’d be happy to create screenshots and source code files for you if that could help you to pinpoint the cause. I can’t open up admin to you even temporarily – sorry.

    There is one plugin I haven’t turned off yet which might have some bearing. It is qtranslate. I’ve got English and French versions of the pages. This is a pretty popular plugin for anyone wanting multi-lingual web sites. It is very closely linked to the WP core files. I’m kind of scared of deactivating it and losing all the work I’ve done to translate the site to French. Let me know if you think this might be the cause.

    BTW I’ve deleted and reloaded your plugin and that had no effect.

    I must confess there is no other WP plugin I can see that has the same functionality as yours. I know someone else who is using it (Pro version) and I’ve got content access to that web site and I can see how the tools are suppose to work when it is working correctly. So I’m rather keen to resolve this problem if I can.

    Thanks Daniel.

    Plugin Author danieliser


    Are you by chance using Qtranslate? NVM i see it at the end but have already typed all this. I have seen the error `TypeError: td is null
    td.parentNode.insertBefore(qtd,td);` before.

    There is a bug in their JS that i am still tracking down. It is caused i believe because the easy modal settings pages are possibly missing some element or classes on elements that QTranslate is looking for but i havent had any luck finding whats missing and their docs dont hint to anything.

    event.returnValue is deprecated.

    As for the above that can’t be related to our code. I just did a search on our source and we don’t user returnValue anywhere. I will load up a site in chrome and check that to be sure its not being returned from our scripts.

    You might double check this first or backup but i am pretty sure that qtranslate doesnt delete your settings and verbage when you deactivate. Try deactivating and adding your modal the reactivate. This obviously isn’t ideal but to be honest i am right at the end of a 2.5 months project and won’t have time to address it properly until we launch in the next 2 weeks. I hate that response but its the honest truth.

    I have already cleared nearly a month before our next private project to not only fully update the docs and content on the website, but plan on fixing the handful of bugs found in the last 2 months as well as adding several new features ( both free and pro ) and several addon packs for the pro developers edition such as advanced animations, analytics ( probably not this wave of updates but in the future ).

    We are actively supporting though so if its something we can fix quickly i will make it happen.

    Hope this is at least informative if not helpful

    Yep. The problem was that bug in qTranslate. Here’s what I’ve done:

    1- Backup (using BackWPup plugin)
    2= Deactivated qTranslate
    3- Deleted and re-installed and re-activated Easy Modal

    Easy Modal dashboard functions are now working! But I have quite a mess on my hands. When I deactivated qTranslate, all of the language versions of every page were “combined” into a single page. So now the English HTML comes first then, at the end of that, the French HTML is appended. My menu is the same (both labels appear).

    It’s also impacted my functions.php in my child theme where I had put some conditional coding based on the language chosen.

    Ignoring all this, I pressed on and created my first modal and put a Contact 7 Form shortcode and created a test page and tried it out. No go. So I removed the shortcode and just put a bit of text. No go. The modal appears on the page (as a link and button) but doesn’t pop up or do anything when I click on it. I’ve tried the link and the button. Neither works.

    I’m supposed to have a meeting with my client in 2 hours so I’ve got to get cracking to fix up this mess. I’ll revert it all to English only for now so I have something to show at my meeting.

    I’ll contemplate where I’m going after I do that. I’m happy to hear what you think I should do next.

    Follow up. I have another plugin called Justified Image Grid which is no longer working at all. This one is important to me. I can’t live without it. So I have no choice but to delete Easy Modal. I’ve done that but my JIG is still not working so I’ll have to reinstall it. It’s a manual install which I haven’t done very often so I’ll have to find my original notes.

    Sorry Daniel. Chalk it up to experience about how you can really screw up your web site when trying to overcome a plugin incompatibility.

    Another follow up. Just discovered that my Meta Slider is no longer working. I’m going to try re-installing WordPress.

    Re-installing didn’t work either. So I’m trying to restore from my backup.

    I tried several times to import my backup file using PHPmyadmin but my line is playing up at the moment and the tar file is close to 200Mb so this was not working. Instead, I reinstalled qtranslate. Presto. The web site is back! Phew.

    Plugin Author danieliser


    Glad to hear you got it back up. I will try to find a solution if i can find some downtime this week.

    I’m not even sure where to begin about the list of problems you experienced. Not sure if thats due to deactivating QTranslate or what.

    I think my problems were all caused by the de-activation of qTranslate. The dashboard conflict disappeared once I de-activated it. I was not able to get any modal to work but I had such a mess from the de-activation that it was not possible to isolate the cause. Once I re-activated qTranslate, the mess was largely fixed.

    Sadly, qTranslate seems very popular (1.1 million downloads) so anyone using it will probably experience a conflict with your plugin. You need to decide how important those 1.1 million users are to you. To get them to use your plugin you either have to debug qTranslate or find a workaround on your own that eliminates the conflict. Not fun.

    Good luck.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Plugin doesn't seem to do anything at all’ is closed to new replies.