RecipePress reloaded
[resolved] Plugin does not work. Unfexpected parse error (3 posts)

  1. mprivat
    Posted 1 year ago #

    Hi out there,

    i was just trying to install wonderful your plugin. It all went well except since i tried to create my first recipe.

    The page does not show proberly. Isnstead of listing "ingridients" there is a failure-notice saying:

    Parse error: syntax error, unexpected '[' in /www/.../wp-content/plugins/recipepress-reloaded/templates/metabox_ingredients.php on line 4

    Can you help me?

    I am running WP 3.9.1 and version 0.5.6 of your plugin. php Version is 5.1.7


  2. Jan Koester
    Plugin Author

    Posted 1 year ago #

    This is a nasty little bug. You can fix it manually by changing line 4 in ../recipepress-reloaded/templates/metabox_ingredients.php to
    $ingredient_link = RPReloaded::get_option('recipe_ingredient_links');
    and in ../recipepress-reloaded/templates/metabox_instructions.php change line 3 to $images = RPReloaded::get_option('recipe_instruction_image');

    Your PHP version throws an error where mine did not, so I could find this error during testing. Please understand that I can not test the plugin again multiple PHP versions.

    This fix will also be included in the upcoming releasen 0.6.0 of recipepress-reloaded.


  3. mprivat
    Posted 1 year ago #

    Wow, what a quick reply! It worked like charme! Thank u so much! Great work!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • RecipePress reloaded
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.