Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Sayontan

    (@sayontan)

    However the flickr embed, which had previously worked great

    Are you saying Photonic was working previously? If so, did something change on your site recently? E.g. did you add any new plugins?

    Photonic has no redirection of any sort anywhere in the plugin, so if nothing else has changed on your plugin, this message would seem to be originating directly from Flickr. What is your Flickr user name? Are you using authentication for Flickr?

    I deactivated the plugin I added two weeks ago, but it did not help. No other recent changes.

    Flickr user name is USDiplomacyCenter (usdiplomacycenter@yahoo.com). We authenticated our account a while ago

    I also get the too many redirects error when I enter my username on the Choose Type of Gallery page.

    Plugin Author Sayontan

    (@sayontan)

    When I simply pass in your user name I am able to see content without issues.

    Try getting rid of the authentication credentials. You can do so by deleting the values under Photonic → Settings → Flickr → Flickr Settings → Access Token (for Back-end / Server-side Authentication) and Photonic → Settings → Flickr → Flickr Settings → Access Token Secret (for Back-end / Server-side Authentication), and then saving the settings. See if that makes a difference.

    Hm, those are currently blank.

    Should I delete my API keys?

    Plugin Author Sayontan

    (@sayontan)

    Should I delete my API keys?

    No, the API keys are required.

    So, was this working for you until recently?

    I looked up Google and the only suggestion that seemed to make sense was that some of the Flickr server farms were causing an issue… but that is not true in your case, since I am able to pull up your albums without a hitch.

    This would imply that there is a different plugin (maybe a security plugin or a firewall plugin) or a server configuration setting that is causing this to happen. So far with Photonic there has only been one other issue reported regarding redirection, and in that case the culprit was a setting in the user’s .htaccess file.

    What setting was that? Perhaps mine is identical.

    Plugin Author Sayontan

    (@sayontan)

    If you go through the linked thread, the user didn’t specify what setting it was – he just mentions that there was a stale 301 redirect in place.

    Generally redirect settings may be put in place by permalink plugins, or permalink settings in your .htaccess file. Also, users tend to put in redirection settings if they are moving from one domain to another, or if they are switching from http to https. Do any of these apply to you?

    A simple thing to try might be to temporarily change your permalink settings (and save), then reset them to what you currently have.

    Is there a good online article or could you explain how to change to recommended permalink settings?

    Plugin Author Sayontan

    (@sayontan)

    Certainly not within Photonic documentation, as Photonic doesn’t deal with redirection.

    Your best bet would be to Google it – in the rare occasions where I have had permalink / redirection issues that is how I have resolved them.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.