Support » Plugin: Mailgun for WordPress » Plugin Does Not Support PHP 8.0

  • Resolved swerley

    (@swerley)


    Hi there,

    Our team recently realized that this plugin does not support PHP 8.0. This caused the plugin to stop delivering emails altogether.

    Do you anticipate you’ll be updating the plugin to support PHP 8.0 in the near future?

    Thanks!

    Scott

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m also seeing an incompatibility with PHP 8.0 on Kinsta. Lots of errors in the log:

    2022/08/26 16:50:03 [error] 11938#11938: *151555 FastCGI sent in stderr: "PHP message: PHP Warning: extract() expects parameter 1 to be array, null given in /www/sitename.com/public/wp-content/plugins/mailgun/includes/wp-mail-api.php on line 117" while reading response header from upstream, client: 1.1.1.1 , server: sitename.com, request: "POST / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php7.4-fpm-sitename.sock:", host: "sitename.com:36145", referrer: "https://sitename.com/"

    Plugin Author omykhailenko

    (@omykhailenko)

    Hello @swerley
    Yes, we are going to add supporting of php 8.0 to the plugin in the future. Our current plan is next week. Because have it in progress already

    Plugin Author omykhailenko

    (@omykhailenko)

    Hello @razorfrog @swerley
    Plugin was updated for supporting php 8.0

    Thread Starter swerley

    (@swerley)

    This is great news. Thank you for the update @omykhailenko!

    Does it also support PHP 8.1? Since 8.0 is basically dead in a couple months.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.