Support » Plugin: Post Thumbnail Editor » Plugin does not always load – white screen

  • Resolved nicholascooper

    (@nicholascooper)


    I have an issue where sometimes the editor does not load, url: wp-admin/upload.php?page=pte-edit&pte-id=228

    failed
    Uncaught TypeError: Cannot read property '0' of undefined main.js:814
    Uncaught Error: Load timeout for modules: cs!csmain_unnormalized2
    http://requirejs.org/docs/errors.html#timeout

    Instead I get a JS error and nothing shows up at all.

    It feels to me like a race condition due to it sometimes working.

    I have been investigating the ajax call ‘get-thumbnail-info’, I thought maybe that was running before the page is ready for content.

    http://wordpress.org/extend/plugins/post-thumbnail-editor/

Viewing 7 replies - 1 through 7 (of 7 total)
  • nicholascooper

    (@nicholascooper)

    In the latest error I can see that a call was never made to ajax get-thumbnail-info

    Plugin Author sewpafly

    (@sewpafly)

    Go to Settings → Post Thumbnail Editor and enable the debug interface. (This changes the loading from one file to several unobfuscated files). Hopefully this will give you a better error message.

    Other thoughts:

    • Which browser are you using?
    • Have you tried disabling all other plugins?
    • Does this happen for every image. every time. or just sometimes?
    gumstaff

    (@gumstaff)

    I am experiencing the same thing.
    I turned debugging on, so we’ll see.

    It happens about 30% of the time, I get a blank white screen. I refresh and it always loads the 2nd time.

    gumstaff

    (@gumstaff)

    Turning on debugging mode seems to have eliminated the problem.

    It also solved another issue I was having. After uploading a new image sometimes the screen would hang and I would be unable to add captions or press the set as featured image button. I would have to reload the page and go through the process again, although the image had uploaded correctly

    Plugin Author sewpafly

    (@sewpafly)

    Thanks gumstaff – I run 99% of the time in debugging mode, so i’ll disable debugging and see if i can find the problem.

    titan21

    (@titan21)

    I had this issue today and found this thread http://wordpress.org/support/topic/edit-image-image-does-not-show-up?replies=10

    Basically – check your functions.php and see if there is any leading or trailing whitespace – if there is – delete it! Had me scratching my head for about an hour but now all fixed! 🙂 Not sure this will help everyone but it worked for me!

    Plugin Author sewpafly

    (@sewpafly)

    Thanks @titan21!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plugin does not always load – white screen’ is closed to new replies.