WordPress.org

Support

Support » Plugins and Hacks » DMSGuestbook » [Resolved] [Plugin: DMSGuestbook] German umlauts in email notification

[Resolved] [Plugin: DMSGuestbook] German umlauts in email notification

  • tmconnect

    @tmconnect

    If using german umlauts in the text-filed and receiving the notification email the umlauts are not showing up correctly e.g. ä gets ä.

    Does anyone know how to solve this problem. Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author DanielSchurter

    @danielschurter

    Hi tmconnect

    DMSGuestbook is using an external mail library (phpmailer) and the default setting of charset is “iso-8859-1”. Depends of your system and setting, umlauts will be shown not correct on your mail client.

    You can change that:
    Go to in your …/plugins/dmsguestbook/phpmailer (php4 or php5-6) folder and open the file class.phpmailer.php with an text editor.
    Search the variable var $CharSet = 'iso-8859-1'; at the beginning of code and change that to var $CharSet = 'utf-8';. That should works.

    Greetings,
    Dani

    tmconnect

    @tmconnect

    Thanks for your help. Now the mail notifications are correct.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: DMSGuestbook] German umlauts in email notification’ is closed to new replies.
Skip to toolbar