WordPress.org

Support

Support » Plugins and Hacks » Counterize » [Resolved] Plugin displays error after upgrading to WP 3.5

[Resolved] Plugin displays error after upgrading to WP 3.5

  • The following message appears after upgrading to WP 3.5:
    Warning: Missing argument 2 for wpdb::prepare(), called in /homepages/39/d377544976/htdocs/coastal/wp-content/plugins/counterize/counterize_plugin_keywords.php on line 274 and defined in /homepages/39/d377544976/htdocs/coastal/wp-includes/wp-db.php on line 990
    Not sure what aspect this affects, and I know it hasn’t been tested with the latest version of WordPress, but I hate to have to replace this plugin with another traffic monitor.

    Any suggestions?

    http://wordpress.org/extend/plugins/counterize/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Drew

    @dpowellscrrcom

    I’m having similar random errors with WP 3.5

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/12/9963412/html/wp-content/plugins/counterize/counterize_plugin_browsers.php on line 281 and defined in /home/content/12/9963412/html/wp-includes/wp-db.php on line 990

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/12/9963412/html/wp-content/plugins/counterize/counterize_plugin_browsers.php on line 282 and defined in /home/content/12/9963412/html/wp-includes/wp-db.php on line 990

    I have many more errors in my output but just wanted to include a few.

    The same results appear on my sites. Clearing the database clears the messages, but they reappear as soon as a new visitor comes by. Deleting the plugin and re-installing has the same result.
    I left another post today (12/16) to see if any alternatives can be suggested by fellow members. I really like having the data available, but not if errors are displayed constantly.

    The author needs to update his plugin!

    PHP Warning: Missing argument 2 for wpdb::prepare()

    Same here, e.g.:

    Missing argument 2 for wpdb::prepare(), called in /server/root/wp-content/plugins/counterize/counterize_plugin_outlinks.php on line 351 and defined in /server/root/wp-includes/wp-db.php on line 990

    Same for me. WordPress 3.5.

    I would suggest using Wp SlimStat as a replacement 😉 It looks like Counterize is not being updated any longer.

    http://wordpress.org/extend/plugins/wp-slimstat/

    Cheers
    Camu

    Plugin Author GabSoftware

    @gabsoftware

    Hi all,

    A fix has been released to address this particular issue.

    The development of Counterize is currently on hold because I don’t have much free time currently.

    Thank you for using Counterize and have a nice day!

    Gabriel

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Plugin displays error after upgrading to WP 3.5’ is closed to new replies.
Skip to toolbar