WordPress.org

Support

Support » Plugins and Hacks » Diamond MultiSite Widgets » [Plugin: Diamond MultiSite Widgets] Diamond Multisite Plugin display problem

[Plugin: Diamond MultiSite Widgets] Diamond Multisite Plugin display problem

  • On my testsite, I’ve installed a wordpress network.

    The first blog is: mytutorials.nl

    The second blog is: mytutorials.nl/blaat

    On the index of the first blog, I’ve added the following code:
    <?php echo do_shortcode('[diamond-post format="{title}: {excerpt}{more}" exclude=1 count=3]'); ?>

    This ensures that on the index of the first blog the titles+excerpts from the second blog are displayed on top of the first blog. (I’ve made it extra ugly so the difference is clear.)

    This works all perfect but when I apply this on my real blog with all the institutions exactly the same (I’ve checked this multiple times), nothing is displayed. When I remove ‘exclude=1’, the excerpts+titles from the first blog are displayed so I think that there is a problem in the connection or so?

    My knowledge of php is too small to solve it myself so I hope someone can helpe me out here.

    Thanks!

    http://wordpress.org/extend/plugins/diamond-multisite-widgets/

Viewing 14 replies - 1 through 14 (of 14 total)
  • anyone??

    bump!

    Daniel hasn’t answered yet? Did you try his website?

    What’s the different between the test and the real site? Local vs webbased?

    Nope,

    I tried his email adres and the contact form but still no response.

    There is no difference, they are both web based.
    In the settings the second blog also doesn’t show up (for example if you want to exclude one blog trough settings) so I guess that there is an problem in the connection or so?

    Differences between two servers or are both on the same?
    Just a thought. Perhaps it makes a difference if you network activate the plugin or activate it per subsite.

    Both websites are hosted by hosted.nl so I guess the same server?
    I already tried the ‘network activate’ option but it didn’t work. I also tried several other combinations of options but just can’t get it work.

    So I started to look further:
    My htaccess files are the same.
    But when I looked trough the config.php file I found a difference:
    In the blog that workes, I made the $table_prefix = ‘wp_multiple’; (‘multiple’ was made up by me trough the installation if I remember correct).
    In the blog that doesn’t work, I didn’t adapt the $table_prefix so it’s still ‘$table_prefix = ‘wp_’;’. Maybe this is the reason that it isn’t working?

    I can hardly imagine. I don’t use the wp_ prefix myself, so if the prefix is hardcoded in the plugin, mine wouldn’t work either.
    Did you perhaps copy the settings or something or did you install the plugin on the new site anew and made the settings again?

    Btw, just thinking after rereading your original post. In the settings screen you can exclude (sub)sites, so why would you exclude one in the shortcode? Could you try exclude site=1 in the settingsscreen and remove that exclude part from the code?

    You are right. I just removed the prefix and it is still working on mytutorials.

    I don’t know exactly what I did, because It was quite some work to get it up and running, but u did use mytutorials as an example. Some settings have been copied, but I guess not all? All wordpress settings are at least the same. And the htacces, I’ve also copied those settings..

    Yeah, I was just wondering if copying settings could also mean copying a table prefix that does not exist in the other setup.

    And that exclude part? Any luck with that?

    No, I didn’t copy the plugin, I made a clean install.

    The Exclude:
    I placed exclude site=1 in the shortcode because in the wp plugin settings screen only the main blog is displayed. There I can’t choose to exclude or white list the second blog.
    (on my testsite, the two blogs are displayed in the settings –> I think this is the part where something goes wrong)

    I think if I can get both blogs displayed in that settings, they will also be displayed on the index..

    I’m been looking through my network a bit.
    I’ve got the plugin network activated. I only see it in the plugin list when I’m in the network admin screen, not in the plugin lists of any of the sites (main or sub). All sides do have the settings screen, displaying 5 (4 sub, 1 main) sites, that’s all but one! The differnence from this last subsite is that I have it set invisible for search engines under ‘settings’->’privacy’. That (news) subsite uses but one widget of the plugin (sitewide comments), for the recent posts in the sidebar I use another plugin (featured blog) and I use the Diamond plugin to display the latest posts overall in a sticky post using shortcodes.

    Would the privacy setting lead to something?

    WHOOOOOO YOU’RE GOOOOD ROY!:D:D

    The privacy settings did it. When I allowed the search engines, the sub site pops op in the settings and also on the index.

    Thanks a lot for all your time and responses!!!

    Not sure why it’s made that way, but I love the plugin, so that explains the effort 🙂

    I do like the plugin as well, except the fact that setting up took 2 weeks 😛

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: Diamond MultiSite Widgets] Diamond Multisite Plugin display problem’ is closed to new replies.
Skip to toolbar