WordPress.org

Support

Support » Plugins and Hacks » Dean's FCKEditor For WordPress » [Plugin: Dean's FCKEditor For WordPress] Strips HTML Code Out: How to Prevent That?

[Plugin: Dean's FCKEditor For WordPress] Strips HTML Code Out: How to Prevent That?

  • When I click the Source button and enter the blog post source with HTML in it, the HTML is stripped out of it.

    How do I just add strait HTML code (with encoding) and not have the editor strip it out?

    Here is an example below.

    <DIV style=’padding: 5px 5px 5px 5px; border-style: dashed none dashed none; border-width: 1px;’><DIV style=’background-color: FFFFCC; color: 000000;’><small><font color=’FF0000′><b>TIP!</b></font> A great tip that can help you fight stress is to simply exercise. Exercising is great because it releases chemicals in your body that will make you feel better.</small></DIV></DIV>

    Changes to:

    <div style=”padding: 5px; border-style: dashed none; border-width: 1px;”>
    <div style=””><small><font color=”FF0000″><b>TIP!</b></font> A great tip that can help you fight stress is to simply exercise. Exercising is great because it releases chemicals in your body that will make you feel better.</small></div>
    </div>

    http://wordpress.org/extend/plugins/fckeditor-for-wordpress-plugin/

Viewing 2 replies - 1 through 2 (of 2 total)
  • FYI

    I edited the file /wp-content/plugins/fckeditor-for-wordpress-plugin/ckeditor/config.js and added these entries and the editor still strips out HTML code and encoded characters out of the blog post.

    config.entities = false;
    config.entities_greek = false;
    config.entities_latin = false;

    I was having similar issues and like Glennf I had posted those config options into the config.js file, with no joy. I was actually trying to use a contact form plugin, and the CKEditor kept changing double quotes into the HTML equivalent, when saving in visual mode (which the client who owns the site was always doing).

    Anyway, I was actually using Dean’s FCKEditor, and by switching to just CKEditor v3.6.2.1 as well as adding the config settings above into the config.js, I managed to resolve my issue.

    Glennf, if not already using that plugin, maybe worth a shot

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Dean's FCKEditor For WordPress] Strips HTML Code Out: How to Prevent That?’ is closed to new replies.
Skip to toolbar