WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Dave's WordPress Live Search] Exceptions not working

[Plugin: Dave's WordPress Live Search] Exceptions not working

  • Hey, I love the plugin so far… it looks very nice, it’s easy to setup, and it’s very useful.

    However, a problem that I was having the whole morning was to exclude some pages from the search results.

    Now I know this is a feature, but it doesn’t seem to work for me.

    I inputed my permalink to the page I wanted to exclude:

    http://www.webpagescreenshot.info/img/32921-327201181120pm.png

    But in the live search it’s still appearing. You can try it here:

    http://www.technocliq.com/

    I have cleared the cache multiple times and even installed the Simply Exclude plugin but it’s just excluded from the normal search results (that’s why you don’t see it there).

    Some help will be appreciated, thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Also the spinning wheel/loading animation is not showing, how can i get that to replace the search icon when loading the results and after the results are loaded, get it to show my search icon once again.

    Thanks.

    never mind for the second post, i figured it out… however i still need help on the first and main post.

    However, a problem that I was having the whole morning was to exclude some pages from the search results.

    Please read the note above the text box again.

    Yeah i wrote that and read it again, why?

    Technocliq: How did you solved your problem in the second post?

    I just don’t get the Exceptions to work… :/

    boddiz, the spinning wheel problem is likely related to something in your theme setting a higher z-index than the default and overlapping the animation.

    The latest development version should fix that for you: http://downloads.wordpress.org/plugin/daves-wordpress-live-search.zip (it forces the animation to have a really high z-index)

    If it passes testing this week, expect this newest version to be released as v2.1 before the weekend.

    I use that plugin together with Relevanssi. In Relevanssi I have excluded some pages to display, but in Live Search they still show up.

    I must say that the Exceptions doesn’t work for me as well.
    to Dave Ross: Your suggestion is to use “?page_id=123” or “page_id=1*”
    If i put the “?” in that field it gives this error(on front end)
    Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /var/www/events/wp-content/plugins/daves-wordpress-live-search/DavesWordPressLiveSearch.php on line 353

    no matter how I tried to play with possible permalink structure in the exception textbox I was not able to make it work.
    (my permalink structure: /%post_id%/%postname%/)
    I have tried:

    page_id=1131
    p=1131
    contact
    contact/
    .
    .

    oki, here is my answer to my self.

    The problem was that I use the xlanguage and that the apply_filters(“localization”,…. doesn’t work within his plugin. don’t know why that filter doesn’t work in there.
    I made my small hack to his plugin (DavesWordPressLiveSearchResults.php row 110 where he assigns the title result to the output):

    here it is:

    $tmp_title = $result->post_title;
    			$exploded_title = explode('|', $tmp_title);
    			if(count($exploded_title) > 1){
    				if (xlanguage_current_language_code() == "en-us"){
    					$result->post_title = $exploded_title[0];
    				}else{
    					$result->post_title = $exploded_title[1];
    				}
    			}else{
    				$result->post_title = $result->post_title;
    			}

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Dave's WordPress Live Search] Exceptions not working’ is closed to new replies.