Support » Plugin: Google Analytics Dashboard for WP (GADWP) » Plugin dashboard is not working after update.

  • Resolved amazinghacker

    (@amazingdropout)


    Last night I have updated this and its seems to stop working. It’s not displaying any data on dashboard. The only data I can see is the “REALTIME” feature.
    I have deactivated and deleted, authorized it again, cleared the plugin cache as well as my server and wp-rocket’s cache.
    I have also deactivated all other plugins but NO LUCK.
    Please help 😀 😀 😀
    Thanks in advance.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Alin Marcu

    (@deconf)

    Hi,

    It seems very similar to this: https://wordpress.org/support/topic/no-data-display-after-update/

    Can you follow all the checks posted there and let me know the results?

    I am having the same problem since updating to 4.9.4 version. When I check Errors, I get the following info:
    Last Error: 2016-12-04 19:44:54: exception ‘Google_Auth_Exception’ with message ‘Error refreshing the OAuth2 token, message: ‘{
    “error” : “invalid_grant”
    }” in /home/content/54/2776154/html/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php:331
    Stack trace:
    #0 /home/content/54/2776154/html/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php(264): Google_Auth_OAuth2->refreshTokenRequest(Array)
    #1 /home/content/54/2776154/html/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php(240): Google_Auth_OAuth2->refreshToken(‘1/CkrZEK8pIjGSN…’)
    #2 /home/content/54/2776154/html/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Service/Resource.php(215): Google_Auth_OAuth2->sign(Object(Google_Http_Request))
    #3 /home/content/54/2776154/html/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Service/Analytics.php(2017): Google_Service_Resource->call(‘get’, Array, ‘Google_Service_…’)
    #4 /home/content/54/2776154/html/wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(773): Google_Service_Analytics_DataRealtime_Resource->get(‘ga:117477686’, ‘rt:activeUsers’, Array)
    #5 /home/content/54/2776154/html/wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(851): GADWP_GAPI_Controller->get_realtime(‘117477686’)
    #6 /home/content/54/2776154/html/wp-content/plugins/google-analytics-dashboard-for-wp/admin/ajax-actions.php(108): GADWP_GAPI_Controller->get(‘117477686’, ‘realtime’, ‘false’, ‘false’, false)
    #7 [internal function]: GADWP_Backend_Ajax->ajax_item_reports(”)
    #8 /home/content/54/2776154/html/wp-includes/plugin.php(524): call_user_func_array(Array, Array)
    #9 /home/content/54/2776154/html/wp-admin/admin-ajax.php(91): do_action(‘wp_ajax_gadwp_b…’)
    #10 {main}

    I don’t know what any of this means or how to fix. Any help would be appreciated. Thank you.

    Plugin Support Alin Marcu

    (@deconf)

    Hi,

    Follow the steps mentioned above and clear the authorization and re-authorize.

    I tried following those steps. I cleared the cache, I forced a page refresh, I cleared the authorization and re-authorized and am still getting an error. This is the error I get:
    Last Error: 2016-12-04 20:07:00: (403) Error calling GET https://www.googleapis.com/analytics/v3/management/accounts/~all/webproperties/~all/profiles?start-index=1: (403) User does not have any Google Analytics account.

    I do have a Google Analytics account so I don’t understand why I am getting this error.

    Ok, I just tried to re-authorize again and this time it worked. I don’t know what happened the first time and why I got that error, but it seems to be working now. Thanks.

    Thanks @alin for your kind support. What I did was..
    1. Clear the authorization and re-authorize the plugin.
    2. Clear cache of your browser as well.
    3. You’re done. 😀 😀 😀
    Thanks again for 404 feature. 😀 😀 😀

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Plugin dashboard is not working after update.’ is closed to new replies.